This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 245574 - [RHEL5.1][BUG][XEN] Windows guest hangs when using USB tablet device.
[RHEL5.1][BUG][XEN] Windows guest hangs when using USB tablet device.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lalancette
Virtualization Bugs
: OtherQA
: 334861 (view as bug list)
Depends On:
Blocks: 246139 246258 296411
  Show dependency treegraph
 
Reported: 2007-06-25 10:22 EDT by Chris Lalancette
Modified: 2010-10-22 11:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0305
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:19:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for the USB tablet from upstream (3.33 KB, patch)
2007-12-07 09:58 EST, Chris Lalancette
no flags Details | Diff

  None (edit)
Description Chris Lalancette 2007-06-25 10:22:37 EDT
Description of problem:

From Fujitsu:
Windows guest hangs when USB device is using.

How reproducible:
Always on USB tablet

Steps to Reproduce:
Use USB tablet
Guest Windows hangs

Actual results:
USB tablet using makes Windows hang.

Expected results:
USB Tablet works fine.

Additional info:
This issue is already fixed by following patch
changeset: [HVM] Prevent usb driver crashes in Windows
changeset 15228: 677731eb734d
http://xenbits.xensource.com/staging/xen-unstable.hg?rev/677731eb734d

Also refer following mail.
http://lists.xensource.com/archives/html/xen-devel/2007-06/msg00308.ht ml
Comment 1 Red Hat Bugzilla 2007-07-24 20:52:21 EDT
change QA contact
Comment 2 Brian Stein 2007-11-14 11:35:59 EST
Is this resolved in 5.1?
Comment 3 Chris Lalancette 2007-11-14 12:08:17 EST
As far as I can tell, no.  The patch referenced here is not in 5.1.

Chris Lalancette
Comment 5 Chris Lalancette 2007-12-07 09:57:16 EST
There have been a number of gyrations around this code; it seemed to settle down
finally, but the resulting patch looked much different from the one in this BZ.
 I'm attaching an updated copy of the patch here.  Also, I've built some
packages with this patch built in; can Fujitsu test these out and see if the
problem is still fixed for them?  They are available here:

http://people.redhat.com/clalance/rpms/xen-3.0.3-41.el5usb.i386.rpm
http://people.redhat.com/clalance/rpms/xen-libs-3.0.3-41.el5usb.i386.rpm

http://people.redhat.com/clalance/rpms/xen-3.0.3-41.el5usb.x86_64.rpm
http://people.redhat.com/clalance/rpms/xen-libs-3.0.3-41.el5usb.x86_64.rpm

Thanks,
Chris Lalancette
Comment 6 Chris Lalancette 2007-12-07 09:58:45 EST
Created attachment 281261 [details]
Fix for the USB tablet from upstream

This patch is what current 3.1.2 code looks like for the USB problem.  It is
really the following xen-3.1-testing.hg changeset numbers put together:

15154
15224
15252
15311
15370

Chris Lalancette
Comment 7 Issue Tracker 2007-12-12 21:34:03 EST
Hello Chris,

Fujitsu tested your packages upon Comment#5, and confirmed that this issue
was gone.


From Fujitsu:
---------------------------
xen-3.0.3-41.el5usb works well. Windows guests did not hang up.

Thanks,

Internal Status set to 'Waiting on Engineering'

This event sent from IssueTracker by mmatsuya 
 issue 123458
Comment 8 Daniel Berrange 2008-01-03 16:09:26 EST
Fix built for QA

$ brew latest-pkg dist-5E-qu-candidate xen
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
xen-3.0.3-43.el5                          dist-5E-qu-candidate  berrange

* Thu Jan  3 2008 Daniel P. Berrange <berrange@redhat.com> - 3.0.3-43.el5
- Backport USB tablet fixes (rhbz #245574)
Comment 10 Chris Lalancette 2008-02-24 11:36:32 EST
*** Bug 334861 has been marked as a duplicate of this bug. ***
Comment 11 John Poelstra 2008-03-21 00:00:10 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot1--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 12 John Poelstra 2008-04-02 17:40:39 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot3--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 14 errata-xmlrpc 2008-05-21 11:19:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0305.html

Note You need to log in before you can comment on or make changes to this bug.