Bug 245645 - port RHEL5 iscsi root boot mkinitrd fix to Fedora.
Summary: port RHEL5 iscsi root boot mkinitrd fix to Fedora.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: 9
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 435248 (view as bug list)
Depends On:
Blocks: F9Target 435248
TreeView+ depends on / blocked
 
Reported: 2007-06-25 20:50 UTC by Mike Christie
Modified: 2008-10-27 15:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 15:47:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Port RHEL5 iscsi boot mkinitrd fixes to fedora. (1.58 KB, patch)
2007-06-25 20:50 UTC, Mike Christie
no flags Details | Diff

Description Mike Christie 2007-06-25 20:50:22 UTC
Description of problem:

When doing iscsi root boot, mkinitrd should not use the iscsiadm -m session
output since that displays all running sessions. It wants to use the $path value
that is passed into iscsi_set_parameters since that is the specific session
being used for root.

mkinitrd also does not want to dig into the db. It should instead use iscsiadm
because that tool will hide differences in db formats for the app/user.

The code in FC7 looks like it came from a bad patch from IBM, that was later
reverted in RHEL5, but did not get reverted in FC.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mike Christie 2007-06-25 20:50:23 UTC
Created attachment 157810 [details]
Port RHEL5 iscsi boot mkinitrd fixes to fedora.

Comment 2 Lubomir Kundrak 2008-02-08 20:05:29 UTC
This is absolutely necessary for proper iSCSI root support in Fedora >= 8 as
paths of the db changed and thus current code no longer works. This worked for
me perfectly.

Alternetively, this can be done to use the correct paths, but it is not a good
idea at all:

--- /sbin/mkinitrd.orig 2008-02-05 23:21:49.000000000 +0100
+++ /sbin/mkinitrd      2008-02-05 23:21:53.000000000 +0100
@@ -615,6 +615,7 @@ iscsi_set_parameters() {
     tpgt=${ipt[2]}
 
     path=/var/lib/iscsi/nodes/${tgt_name}/${tgt_ipaddr},${tgt_port}
+    [ -d "${path}" ] || path=${path},${tpgt}
 
     # Note: we get chap secrets (passwords) in plaintext, and also store
     # them in the initrd.

Comment 3 Lubomir Kundrak 2008-02-14 02:26:33 UTC
Ping

Comment 4 Peter Jones 2008-03-06 20:06:15 UTC
*** Bug 435248 has been marked as a duplicate of this bug. ***

Comment 5 Peter Jones 2008-03-06 20:08:55 UTC
I'm for this in principle, but have very little time to work on it.  An updated
patch that represents changes to the more recent tree would help, and we also
need to be sure the associated changes to mount, util-linux, and anaconda are
merged.

Comment 6 Lubomir Kundrak 2008-03-06 20:38:14 UTC
Peter? What changes? This patch applies cleanly to the current tree and is the
last thing that is needed for iscsi instalations to work.

I fully understand that you have little time; on the other hand I am sure there
are poeple with enough time out there to help with that. Please consider opening
up access to the source code repository to Fedora contributors in cvsextras
group, or call for a comaintainer in fedora-devel mailing list.

Comment 7 Peter Jones 2008-03-11 20:43:27 UTC
There were several more changes after this patch was prepared, and they also
need to be incorporated.

Also, please understand that this request generally pertains to the upstream
project, rather than to the package itself.

Comment 8 Jon Stanley 2008-04-02 20:33:30 UTC
Moving to F9 target

Comment 9 Bug Zapper 2008-05-14 03:00:34 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Hans de Goede 2008-10-27 15:47:51 UTC
This is fixed in 6.0.68-1, which will be in tomorrows rawhide.


Note You need to log in before you can comment on or make changes to this bug.