This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 435248 - port RHEL5 iscsi root boot mkinitrd fix to Fedora.
port RHEL5 iscsi root boot mkinitrd fix to Fedora.
Status: CLOSED DUPLICATE of bug 245645
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On: 245645
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 03:37 EST by Lubomir Kundrak
Modified: 2008-03-06 15:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 15:06:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2008-02-28 03:37:26 EST
2nd formal attempt to contact maintainer.

+++ This bug was initially created as a clone of Bug #245645 +++

Description of problem:

When doing iscsi root boot, mkinitrd should not use the iscsiadm -m session
output since that displays all running sessions. It wants to use the $path value
that is passed into iscsi_set_parameters since that is the specific session
being used for root.

mkinitrd also does not want to dig into the db. It should instead use iscsiadm
because that tool will hide differences in db formats for the app/user.

The code in FC7 looks like it came from a bad patch from IBM, that was later
reverted in RHEL5, but did not get reverted in FC.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

-- Additional comment from mchristi@redhat.com on 2007-06-25 16:50 EST --
Created an attachment (id=157810)
Port RHEL5 iscsi boot mkinitrd fixes to fedora.


-- Additional comment from lkundrak@redhat.com on 2008-02-08 15:05 EST --
This is absolutely necessary for proper iSCSI root support in Fedora >= 8 as
paths of the db changed and thus current code no longer works. This worked for
me perfectly.

Alternetively, this can be done to use the correct paths, but it is not a good
idea at all:

--- /sbin/mkinitrd.orig 2008-02-05 23:21:49.000000000 +0100
+++ /sbin/mkinitrd      2008-02-05 23:21:53.000000000 +0100
@@ -615,6 +615,7 @@ iscsi_set_parameters() {
     tpgt=${ipt[2]}
 
     path=/var/lib/iscsi/nodes/${tgt_name}/${tgt_ipaddr},${tgt_port}
+    [ -d "${path}" ] || path=${path},${tpgt}
 
     # Note: we get chap secrets (passwords) in plaintext, and also store
     # them in the initrd.

-- Additional comment from lkundrak@redhat.com on 2008-02-13 21:26 EST --
Ping
Comment 1 Peter Jones 2008-03-06 15:06:14 EST

*** This bug has been marked as a duplicate of 245645 ***

Note You need to log in before you can comment on or make changes to this bug.