Bug 245715 - lvs syncdaemon causes 1.00 too high average load on system
lvs syncdaemon causes 1.00 too high average load on system
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anton Arapov
Martin Jenner
http://lists.graemef.net/pipermail/lv...
:
: 247614 (view as bug list)
Depends On:
Blocks: 425461
  Show dependency treegraph
 
Reported: 2007-06-26 05:39 EDT by Tuomo Soini
Modified: 2014-06-18 04:00 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.19 KB, patch)
2007-08-17 07:22 EDT, Anton Arapov
no flags Details | Diff

  None (edit)
Description Tuomo Soini 2007-06-26 05:39:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.12) Gecko/20070531 Foobar/1.5.0.12-0.1.0.foo4 Firefox/1.5.0.12

Description of problem:
Because of bug in kernel adding lvs syncdaemon causes high average load on system without actual load present. Load is 1.00 too high for lvs master and for both master and slave it's 2.00 too high.

Fix need to be backported to get load low again.

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=89eaeb09ba01632511f69ce8e14c8d2abd2dbe9e

Version-Release number of selected component (if applicable):
kernel-2.6.18-8.1.6.el5

How reproducible:
Always


Steps to Reproduce:
1. start lvs sync master with command
# ipvsadm --start-daemon master -mcast-interface eth1 --syncid 0




Actual Results:
Average load goes to 1.00

Expected Results:
Average load should be 0.00 because there was no actual load

Additional info:
Comment 1 Anton Arapov 2007-08-17 07:22:41 EDT
Created attachment 161726 [details]
Proposed patch
Comment 2 Jarod Wilson 2007-09-01 23:40:10 EDT
*** Bug 247614 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2007-11-01 19:55:25 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Don Zickus 2007-11-29 12:06:12 EST
in 2.6.18-58.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 7 Mike Gahagan 2008-05-05 17:30:18 EDT
confirmed fix is in the -92.el5 kernel
Comment 9 errata-xmlrpc 2008-05-21 10:44:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.