Bug 247614 - ipvs_syncmaster / ipvs_syncbackup
ipvs_syncmaster / ipvs_syncbackup
Status: CLOSED DUPLICATE of bug 245715
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-10 09:10 EDT by David Kostal
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-01 23:40:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kostal 2007-07-10 09:10:38 EDT
Description of problem:
Load on the machine running ipvs_syncmaster/backup daemon increases by 1 even if
it's otherwise idle.

Version-Release number of selected component (if applicable):
kernel-2.6.18-8.1.6.el5

How reproducible:
allways

Steps to Reproduce:
1. set up ipvs loadbalancer
2. run: ipvsadm --start-daemon backup --mcast-interface eth0 --syncid 150
3. load slowly increases (on idle machine to 1), top reports 100% idle
4. run: ipvsadm --stop-daemon backup
5. load slowly decreses to "normal' state, eg. 0
  
Actual results:
After starting the ipvs daemon, the load is slowly increasing. On idle machine
to 1.00 -1.20). Top at the same time reports 100% idle time. 

Expected results:
No load increase.

Additional info:
According to my question to keepalived development mailing list
http://sourceforge.net/mailarchive/forum.php?thread_name=f54c1fdb0707100234t74a288d7ta2a35b0a6c91a5cf%40mail.gmail.com&forum_name=keepalived-devel
 the problem is a known bug in ip_vs_sync.c, fixed in cca 2.6.19 in November
last year.


The behaviour was in fact observer on CentOS5/x86_64, but to my best knowledge
it should also affect RHEL5 ;-)
Comment 1 David Kostal 2007-07-11 02:40:50 EDT
It seems that https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=245715 which
I haven't discover before is reporting the same problem. Any news on this issue?
Comment 2 Jarod Wilson 2007-09-01 23:40:09 EDT
(In reply to comment #1)
> It seems that https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=245715 which
> I haven't discover before is reporting the same problem. Any news on this issue?

Looks like the patch has been posted internally for review, but doubtful that it'll make 5.1, since we're 
already quite late in the development cycle. Should easily make 5.2 though.

*** This bug has been marked as a duplicate of 245715 ***

Note You need to log in before you can comment on or make changes to this bug.