Bug 245852 - gtkhml3: font kerning is not working properly
Summary: gtkhml3: font kerning is not working properly
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkhtml3   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 447238 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-26 23:50 UTC by Bernard Johnson
Modified: 2008-06-27 03:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-27 03:21:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example (36.12 KB, application/pdf)
2007-06-26 23:50 UTC, Bernard Johnson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 446894 None None None Never

Description Bernard Johnson 2007-06-26 23:50:25 UTC
Description of problem:
Look at the example file. For example, "Interest Income" as the letters "er" and
"om" touching.  Other distances are suspect as well.

Version-Release number of selected component (if applicable):
gtkhtml3-3.15.4-1.fc8

How reproducible:
Always

Comment 1 Bernard Johnson 2007-06-26 23:50:25 UTC
Created attachment 157968 [details]
example

Comment 2 Matthew Barnes 2007-06-27 03:36:46 UTC
Thanks for reporting this.  I'll try to get the font kerning fixed as part of my
upstream work in this area.  Please see [1] for further updates.

I'll leave this bug open for now to help me track this particular problem.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=446894

Comment 3 Bernard Johnson 2008-01-24 01:29:39 UTC
Matthew, any chance of having a bug fix in the near future?

Comment 4 Matthew Barnes 2008-01-29 19:23:02 UTC
Looks like it fell through the cracks.  I'll try to address this soon.

Comment 5 Bojan Smojver 2008-05-02 05:54:40 UTC
Ping...

Comment 6 Matthew Barnes 2008-05-19 18:03:51 UTC
*** Bug 447238 has been marked as a duplicate of this bug. ***

Comment 7 Johnny Proton 2008-05-19 18:42:03 UTC
If this is an upstream bug, how did they manage to fix it in Ubuntu and keep it
fixed for at least 2 versions now?

Comment 8 Matthew Barnes 2008-05-19 19:19:48 UTC
Ask Ubuntu.  And tell them to share.

Comment 9 Johnny Proton 2008-05-19 21:19:41 UTC
I'll do what you ask me to do if I can, but I can't see if you are joking or
not.  I just know that I can't print anything out from my emails without it
looking like my computer has preschool quality handwriting.

I know it's been working for quite a while in Ubuntu so I'm wondering why it
isn't working in Fedora.

Comment 10 Matthew Barnes 2008-06-27 03:21:37 UTC
I finally have a patch for this in the upstream bug referenced above, so I'm
closing this as UPSTREAM.  Please continue to monitor [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=446894


Note You need to log in before you can comment on or make changes to this bug.