Bug 447238 - Kerning on printed emails is *HORRIBLE*
Kerning on printed emails is *HORRIBLE*
Status: CLOSED DUPLICATE of bug 245852
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 20:51 EDT by Johnny Proton
Modified: 2008-05-19 14:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 14:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Email printed from Fedora (Sans Font, HP2550N Printer, Postscript Driver) (431.01 KB, image/jpeg)
2008-05-18 21:04 EDT, Johnny Proton
no flags Details
Email printed from Ubuntu (Sans Font, HP2550N Printer, Postscript Driver) (430.93 KB, image/jpeg)
2008-05-18 21:05 EDT, Johnny Proton
no flags Details

  None (edit)
Description Johnny Proton 2008-05-18 20:51:52 EDT
I am filing this here because it is a bug that I have only come across in Fedora
distributions.  I have filed it with Gnome and apparently they don't care.

UBUNTU DOES NOT HAVE THIS PROBLEM!

I apologize for the rant here, but someone needs to take care of this!  Hasn't
anyone noticed that printing of any email using a non-monospace font looks like
complete garbage???  I have gone into meetings before with a printed email and
people can barely read what it says.  They ask me what the problem is, and I
have to explain that "I use linux, and that's why it looks like crap."  Not
exactly the best selling point for an operating system, but it is true.

This issue is one that I was desperately looking to have fixed when I upgraded
to v9, and at this point, I am seriously considering switching over to Ubuntu. 
I have already switched 50% of my office to them, because I am more of a power
user than they are and I'm not willing to deal with the same things
professionally as I am personally.

This issue is extremely serious.  You guys are going to lose yet another convert
over to Ubuntu if you can't at least provide me with a way to fix this so it
isn't a problem.  I have been loyal to the Fedora cause for years now, but as I
move forward professionally, I need these *STUPID* little bugs to be addressed,
or at least to know that someone over there takes things like this seriously.
Comment 1 Johnny Proton 2008-05-18 21:04:45 EDT
Created attachment 305884 [details]
Email printed from Fedora (Sans Font, HP2550N Printer, Postscript Driver)

Look at the kerning (the spacing between letters).  It is terrible.  Letters
overlap each other and make it difficult to read a lot of text.
Comment 2 Johnny Proton 2008-05-18 21:05:55 EDT
Created attachment 305885 [details]
Email printed from Ubuntu (Sans Font, HP2550N Printer, Postscript Driver)

As you can see, the kerning is much better in this version.  It is not perfect
or up to par with Windows & MacOS, but it is good enough that the typical
business person would definitely not complain.
Comment 3 Matthew Barnes 2008-05-18 22:49:59 EDT
Probably a difference in fonts.  What fonts are you using in Fedora vs. Ubuntu?
Comment 4 Johnny Proton 2008-05-18 23:20:49 EDT
That's the thing I explorerd earlier.  These are using exactly the same fonts. 
If you explore the JPGs, you'll see that.  The font is "Sans" on both Fedora and
Ubuntu.

I did notice that Ubuntu ships with a whole lot more Foomatic packages including
hpijs stuff, and they were able to automatically detect my network printer where
Fedora was not, but both ended up using the recommended "Postscript" driver so I
don't know why there should be any other difference.

People do print emails though.  I know it's crazy, but they do.  And sometimes,
it's for an important reason.
Comment 5 Matthew Barnes 2008-05-19 14:03:50 EDT

*** This bug has been marked as a duplicate of 245852 ***

Note You need to log in before you can comment on or make changes to this bug.