Bug 245944 - new stable release 1.616
Summary: new stable release 1.616
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ntfs-3g   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 249448 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-27 15:15 UTC by ericm24x7
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 1.710-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 05:22:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ericm24x7 2007-06-27 15:15:25 UTC
Description of problem:
ntfs-3g just released a stable version 1.616 on June 17. Fedora's development
version currently has 1.516. Maybe it would be a good time to rebuild the
package with the new version to resolve some major issues.

Major visible changes since the last stable release:

  o  new: install executables to the root file system otherwise 
          mount could fail during boot
  o  fix: any kind of file size change failure returned 
          "Operation not permitted"
  o  fix: file close failure was not always reported
  o  fix: unmount failure was not always reported
  o  fix: file creation always gave "I/O error" if the $MFT Bitmap
          wasn't up-to-date
  o  fix: converting very long file names to Unicode may failed
  o  fix: syslog messages didn't show the low level error detail

Comment 1 Tom "spot" Callaway 2007-06-27 15:20:06 UTC
We're holding on this, waiting for FUSE to update.

Comment 2 ericm24x7 2007-07-11 00:03:54 UTC
I just compiled the latest ntfs-3g release today (1-710) on existing fuse
development build:
fuse-devel 2.6.5-2.fc8
fuse-libs 2.6.5-2.fc8

Running some integrity tests right now: 
1. Copying files to USB stick (NTFS formated) w/ 8Gb capacity (use md5sum for
checksum), then reverse copy then do checksum to check.
2. Transfering 200GB+ worth of files then do checksum. (files as large as 16GB each)

I'm not sure if the above fuse build has the change(s) you need to update and
build ntfs-3g into fc8.

Comment 3 Tom "spot" Callaway 2007-07-24 21:01:15 UTC
*** Bug 249448 has been marked as a duplicate of this bug. ***

Comment 4 Tom "spot" Callaway 2007-07-24 21:03:23 UTC
I'm going to update ntfs-3g shortly, as soon as fuse is done (doing it right now).

Comment 5 Fedora Update System 2007-07-25 05:22:30 UTC
ntfs-3g-1.710-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.