Bug 245981 - requires later version of gnonlin than packaged in Fedora
Summary: requires later version of gnonlin than packaged in Fedora
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnonlin   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 245869 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-27 19:22 UTC by Paul Jenner
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version: 0.10.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 22:12:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Jenner 2007-06-27 19:22:37 UTC
Description of problem:

Running latest FE6 Pitivi gives error that it requires gnonlin 0.10.6.1 or
greater but only 0.10.5 is packaged for FE.

Version-Release number of selected component (if applicable):
pitivi-0.10.3-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. start pitivi
  
Actual results:
Gives error "You do not have a recent enough version of the GNonLin GStreamer
plugin (currently 0.10.5). Install a version of the GNonLin GStreamer plugin
greater or equal to 0.10.6.1" and fails to start.

Expected results:
It should start :-)

Additional info:
[psj@localhost ~]$ rpm -q --requires pitivi | grep gnonlin
gnonlin

Should that requires be versioned?

Comment 1 Jeffrey C. Ollie 2007-06-27 20:14:07 UTC
I've submitted new builds of pitivi with a versioned require on pitivi, they
should be available from the mirrors soon...  I'm going to re-assign this bug to
gnonlin to see if we can get gnonlin updated...

Comment 2 Brian Pepple 2007-06-27 20:25:22 UTC
Why was pitivi even pushed for FC-6 without contact me first?  Was this just
blindly pushed?

Comment 3 Brian Pepple 2007-06-27 20:26:25 UTC
*** Bug 245869 has been marked as a duplicate of this bug. ***

Comment 4 Jeffrey C. Ollie 2007-06-27 20:28:34 UTC
I had forgotten that I had updated gnonlin locally on my FC-6 laptop when I was
doing the testing...

Comment 5 Brian Pepple 2007-06-27 20:42:00 UTC
This should never have been pushed to FC6, since it hasn't even hit F7 stable
yet.  You are breaking the upgrade path for pitivi.  Please in the future make
sure you are upgrading packages in the correct order (devel, F7, etc.), and
don't just push builds.

BTW, sorry if I come off sounding pissy, but things like this really irk me.


Note You need to log in before you can comment on or make changes to this bug.