Bug 245981 - requires later version of gnonlin than packaged in Fedora
requires later version of gnonlin than packaged in Fedora
Product: Fedora
Classification: Fedora
Component: gnonlin (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: 245869 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-06-27 15:22 EDT by Paul Jenner
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.10.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-27 18:12:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul Jenner 2007-06-27 15:22:37 EDT
Description of problem:

Running latest FE6 Pitivi gives error that it requires gnonlin or
greater but only 0.10.5 is packaged for FE.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. start pitivi
Actual results:
Gives error "You do not have a recent enough version of the GNonLin GStreamer
plugin (currently 0.10.5). Install a version of the GNonLin GStreamer plugin
greater or equal to" and fails to start.

Expected results:
It should start :-)

Additional info:
[psj@localhost ~]$ rpm -q --requires pitivi | grep gnonlin

Should that requires be versioned?
Comment 1 Jeffrey C. Ollie 2007-06-27 16:14:07 EDT
I've submitted new builds of pitivi with a versioned require on pitivi, they
should be available from the mirrors soon...  I'm going to re-assign this bug to
gnonlin to see if we can get gnonlin updated...
Comment 2 Brian Pepple 2007-06-27 16:25:22 EDT
Why was pitivi even pushed for FC-6 without contact me first?  Was this just
blindly pushed?
Comment 3 Brian Pepple 2007-06-27 16:26:25 EDT
*** Bug 245869 has been marked as a duplicate of this bug. ***
Comment 4 Jeffrey C. Ollie 2007-06-27 16:28:34 EDT
I had forgotten that I had updated gnonlin locally on my FC-6 laptop when I was
doing the testing...
Comment 5 Brian Pepple 2007-06-27 16:42:00 EDT
This should never have been pushed to FC6, since it hasn't even hit F7 stable
yet.  You are breaking the upgrade path for pitivi.  Please in the future make
sure you are upgrading packages in the correct order (devel, F7, etc.), and
don't just push builds.

BTW, sorry if I come off sounding pissy, but things like this really irk me.

Note You need to log in before you can comment on or make changes to this bug.