Bug 246024 - State incorrectly states modified
State incorrectly states modified
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: crossvc (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
: 246346 (view as bug list)
Depends On: 246393
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 18:24 EDT by Michael Cronenworth
Modified: 2008-03-25 09:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.5.2-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 04:31:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2007-06-27 18:24:22 EDT
Description of problem: On random source files the state column is flagged as
"modified" even if the file is just checked out of CVS. It seems something with
the date is messed up... Example: Last Updated column: 01-01-2007 Modified
column: 01-17-2007 (this is a freshly checked out file)

The date seems to be "16 days off" but it is not consistant. Sometimes the date
is 10 days off.

This happened after I upgraded from FC6 to F7.


Version-Release number of selected component (if applicable): 1.5.1


How reproducible: Always

  
Actual results: State: modified


Expected results: State: looks up to date


Additional info: This effects remote (pserver) and local CVS repositories.

I even built CrossVC from source (using the tarball from www.lincvs.com) and it
still has the wrong state.

I have a feeling that some tool that CrossVC uses (diff, etc.) got updated in my
FC6 to F7 upgrade and it is messing up CrossVC... so CrossVC is not necessarily
the cause of the problem.
Comment 1 Jochen Schmitt 2007-06-28 12:13:01 EDT
Hello,

I have tried to reproduced you reported bug. On my system, I have seen a file
entry dated on 200706/02, but the file was create toaday (2007/06/26).

I thank, I will check it with the plain cvs to look, if this problem occurs from
CrossvC or from cvs.
Comment 2 Jochen Schmitt 2007-06-28 13:32:31 EDT
I will inform you, that I have sent a bug report to the upstream via mail.
Comment 3 Jochen Schmitt 2007-06-28 16:28:25 EDT
Hello,

I have got a response from the upstream author.

The problem is a bug in qt-3.3.8 in a datetime parsing function.

I will look on bugzillla, if a bug exist and set it as an blocker.
Comment 4 Jochen Schmitt 2007-06-28 16:32:01 EDT
I have not found a related bug in bugzilla.

I will wait for further information from the upstream and will open a related
bug in bugzilla.
Comment 5 Jochen Schlick 2007-06-30 15:24:44 EDT
*** Bug 246346 has been marked as a duplicate of this bug. ***
Comment 6 Jochen Schlick 2007-06-30 15:40:59 EDT
yes, this crossvc bug exists in rawhide/devel for at least two month. And when I
look at the build date of qt-3.3.8 - it's Wed Apr 11 2007 - gotcha
Comment 7 Jochen Schmitt 2007-07-01 13:35:47 EDT
I have got a message from the upstream author, that the described qt bug can be
found as ID 154433 in the Troll Tech Task-Tracker database.

Because this bug may be fixed in qt-3.3.9, the upstream author will try to
develope a workaround patch for this issue.

I hope to be notified, when he has an tested workaround for this issue.
Comment 8 Jochen Schmitt 2007-07-01 13:45:41 EDT
I have create BZ #246393 agains qt and set a dependency on it.
Comment 9 Jochen Schmitt 2007-07-09 13:19:20 EDT
I have got a prerealse of CrossVC-1.5.2 from the upstream.

My tests shows, that the workaround which is implemented in this version works
fine for me. So I have create a package on rawhide which should be available in
the next days.

When I will got the final 1.5.2 release, I will create an update for F-7.
Comment 10 Michael Cronenworth 2007-07-09 13:52:11 EDT
I will try the rawhide build since the date is a huge inconvenience. I'm
surprised that a bug like this (involving date) is not high priority with
Trolltech and a hot fix was not put out for Qt.

Thanks for all your work, Jochen.
Comment 11 Kevin Kofler 2007-07-11 00:06:32 EDT
There will be no Qt 3.3.9, Qt 3 has been discontinued.
http://trolltech.com/products/qt/qt3
Comment 12 Kevin Kofler 2007-07-11 00:10:27 EDT
Cervisia in F7 has the same bug, probably for the same reason.
I think this should be patched in Fedora's Qt package.
Comment 13 Michael Cronenworth 2007-07-12 16:19:02 EDT
I am using the rawhide package on my F7 machine. Works great! Thanks.

Kevin, this bug was reported to Trolltech well before the July 1st deadline, and
no fix was given out. I'm not impressed by Trolltech. (Gnome/KDE are not my DE
anyway)
Comment 14 Fedora Update System 2007-09-10 12:52:11 EDT
crossvc-1.5.1-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Kevin Kofler 2007-09-10 14:48:19 EDT
Your Requires on qt-3.3.8-6 is useless, because that version does NOT contain 
the fix for bug 246393, it's a security update only.
Comment 16 Fedora Update System 2007-09-17 23:16:55 EDT
crossvc-1.5.2-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2007-09-25 04:31:43 EDT
crossvc-1.5.2-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.