Bug 246078 - Wrong dependency calculations: kdebindings-3.5.6->3.5.7 upgrade
Wrong dependency calculations: kdebindings-3.5.6->3.5.7 upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 246395 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 08:23 EDT by Kostas Georgiou
Modified: 2014-01-21 17:58 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.2.2-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 15:48:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum update results (13.59 KB, text/plain)
2007-06-28 08:23 EDT, Kostas Georgiou
no flags Details
yum -d 6 update output (487.86 KB, text/plain)
2007-06-28 08:57 EDT, Kostas Georgiou
no flags Details
another yum -d6 log (31.14 KB, application/x-tar)
2007-06-28 09:12 EDT, Rex Dieter
no flags Details
should sort the 'best' providers by distance from requesting arch (1.60 KB, patch)
2007-07-01 10:33 EDT, Seth Vidal
no flags Details | Diff

  None (edit)
Description Kostas Georgiou 2007-06-28 08:23:32 EDT
With the latest kde update (3.5.7-1.fc7.1) perl(DCOP) is now provided by
kdebindings-dcopperl instead of kdebindings. Unfortunately on multilib systems
yum decides to install kdebindings-3.5.6-1.fc7.i386 (shortest name wins?) even
while at the same time it is about to upgrade the x86_64 version of kdebindings
to the newer version.
Comment 1 Kostas Georgiou 2007-06-28 08:23:32 EDT
Created attachment 158116 [details]
yum update results
Comment 2 Rex Dieter 2007-06-28 08:25:42 EDT
A little background wrt what Kostas is seeing:
perl(DCOP) is provided by both kdebindings-3.5.6 and kdebindings-dcopperl-3.5.7 
(moved to separate subpkg in update).

kdesdk Requires: perl(DCOP)

On existing system with kdebindings-3.5.6, kdesdk-3.5.6, trying to upgrade to
kde-3.5.7 results in transaction trying to install kdebindings-3.5.6.i386 on
x86_64 systems ??  (presumably to satisfy the perl(DCOP) dep using "shortest
named pkg that provides it).

It was suggested that adding to kdebindings-dcopperl:
Obsoletes: kdebindings < 3.5.7
may help.  If so, I'm ok with adding that to kdebindings packaging.
Comment 3 Kostas Georgiou 2007-06-28 08:36:52 EDT
For the record this happens in a machine with no i386 packages installed also.
Comment 4 Seth Vidal 2007-06-28 08:49:41 EDT
can you output a yum -d 6 update, please
Comment 5 Kostas Georgiou 2007-06-28 08:57:25 EDT
Created attachment 158119 [details]
yum -d 6 update output

yum -d 6 update output from a different machine (no i386 packages installed at
all on this machine)
Comment 6 Rex Dieter 2007-06-28 09:12:10 EDT
Created attachment 158121 [details]
another yum -d6 log
Comment 7 Seth Vidal 2007-07-01 10:33:08 EDT
Created attachment 158310 [details]
should sort the 'best' providers by distance from requesting arch

please apply this patch to depsolve.py in yum and see if the problem goes away.

I think it will
Comment 8 Kostas Georgiou 2007-07-01 14:51:15 EDT
No luck with the patch :(, it doesn't do anything in this case since at that
point we have:
best_dist: 1
po_dist:   6
best:      kdebindings-dcopperl - 3.5.7-1.fc7.1.x86_64
po:        kdebindings - 3.5.6-1.fc7.i386
and neither of the if cases are taken so the  lowest name wins replaces
kdebindings-dcopperl with the i386 version of kdebindings right after the code
you added in:
  if len(po.name) < len(best.name):
    best = po

Comment 9 Seth Vidal 2007-07-01 17:46:37 EDT
I didn't add it - I failed to add the 'elif' to it.

Try this for me. on line: 592 - add 'el' to the 'if' that's there.

then rerun
Comment 10 Kostas Georgiou 2007-07-01 18:52:37 EDT
Great, with the elif kdebindings-dcopperl is picked up and everything works
correctly :)

Comment 11 Seth Vidal 2007-07-01 20:01:19 EDT
cool, it's committed and I'm closing this upstream
Comment 12 Rex Dieter 2007-07-02 05:42:29 EDT
*** Bug 246395 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2007-07-23 11:46:28 EDT
yum-3.2.2-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2007-08-15 15:47:40 EDT
yum-3.2.2-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.