Bug 246305 - prism54pci (mac80211) always fails ipv6 duplicate address detection
Summary: prism54pci (mac80211) always fails ipv6 duplicate address detection
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 250252 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-29 22:13 UTC by Mike Bonnet
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version: 2.6.22.1-50.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 17:41:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ipv6 broadcast packets seen by the prism54pci device when adding a link-local ipv6 address (424 bytes, application/octet-stream)
2007-06-29 22:13 UTC, Mike Bonnet
no flags Details

Description Mike Bonnet 2007-06-29 22:13:04 UTC
Description of problem:
When an ipv6 link-local address is added (either automatically or manually) to a
prism54pci (mac80211) device, the address will always be marked "tentative", and
a "duplicate address detected!" message will be output in syslog.  This is
definitely not a duplicate address.  It looks like the device is seeing its own
broadcast packets, that the kernel sent out to perform ipv6 Neighbor Discovery.
 This may be similar to this bug:
http://bughost.org/bugzilla/show_bug.cgi?id=265

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3228.fc7

How reproducible:
always

Steps to Reproduce:
1. flush ipv6 addrs from the device (for consistency)
# ip -6 addr flush wlan1
2. manually add a unique ipv6 addr to the device
# ip -6 addr add fe80::209:5bff:feea:c06f/64 dev wlan1 scope link
3. look in syslog for the "duplicate address detected!" message
4. see that the address has been marked tentative
# ip -6 addr show wlan1
7: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
    inet6 fe80::209:5bff:feea:c06f/64 scope link tentative 
       valid_lft forever preferred_lft forever

Actual results:
"duplicate address detected!" in syslog, address is marked tentative and is unusable

Expected results:
no duplicate address detected, address not marked tentative

Additional info:
attached a wireshark capture of the ipv6 broadcast packets that the device sees
when the address is added

Comment 1 Mike Bonnet 2007-06-29 22:13:04 UTC
Created attachment 158274 [details]
ipv6 broadcast packets seen by the prism54pci device when adding a link-local ipv6 address

Comment 2 John W. Linville 2007-08-01 14:09:26 UTC
FWIW, I think this is a generic mac80211 problem.

Comment 3 John W. Linville 2007-08-02 18:51:00 UTC
*** Bug 250252 has been marked as a duplicate of this bug. ***

Comment 4 John W. Linville 2007-08-07 18:02:39 UTC
Please try the kernels here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=13002

Do these avoid the "duplicate address" problem?

Comment 5 Pekka Savola 2007-08-08 05:05:20 UTC
Kernel 46 from koji seems to fix the problem on zd1211rw and IPv6 now works fine
(it appears as if IPv4 DHCP setup is much faster as well, but I didn't test it
thoroughly).  Thanks!


Comment 6 Mike Bonnet 2007-08-10 00:28:59 UTC
2.6.22.1-50 no longer exhibits the "duplicate address" problem.  Awesome, thanks
John!



Note You need to log in before you can comment on or make changes to this bug.