Bug 250252 - zd1211rw-mac80211 breaks multicast and IPv6
zd1211rw-mac80211 breaks multicast and IPv6
Status: CLOSED DUPLICATE of bug 246305
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 09:02 EDT by Pekka Savola
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-02 14:50:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2007-07-31 09:02:46 EDT
Apparently, moving from zd1211rw to zd1211rw-mac80211 broke multicast (you
receive the multicast frames you sent) which in turn broke IPv6, see:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233364

A report sent on netdev a couple of times, but no response.  Slightly updated
version below.

On Fedora 7 (kernel 2.6.21-1.3228.fc7, based on 2.6.21.5; also kernel
2.6.22.1-41.fc7), my zd1211rw_mac80211 WLAN USB stick and multicast/v6 no longer
works. On Fedora 6 (kernel 2.6.20, no mac80211) it was OK.

I get "wlan0: duplicate address detected!" on dmesg when the kernel is trying to
autoconfigure a global address.

I suppose this is caused by the IPv6 stack seeing my own ICMPv6 neighbor
solicitation and thinking it was originated by someone
else:

08:46:21.762807 00:02:72:5b:dc:28 > 33:33:ff:5b:dc:28, ethertype IPv6 (0x86dd),
length 78: (hlim 255, next-header: ICMPv6 (58),
length: 24) :: > ff02::1:ff5b:dc28: [icmp6 sum ok] ICMP6, neighbor solicitation,
length 24, who has
2001:708:10:90:202:72ff:fe5b:dc28

Strangely, the same error isn't printed with the link-local address which uses
the same EUI-64.

z1211rw Wiki seems to imply that this might be an issue in generic mac80211 code:

http://www.linuxwireless.org/en/users/Drivers/zd1211rw/mac80211Issues

.. however, I suspect that there would have been a bigger outcry if that had
been the case.
Comment 1 John W. Linville 2007-08-02 14:50:53 EDT

*** This bug has been marked as a duplicate of 246305 ***

Note You need to log in before you can comment on or make changes to this bug.