Bug 246335 - Democracy DBus error - fails to launch
Democracy DBus error - fails to launch
Status: CLOSED DUPLICATE of bug 244889
Product: Fedora
Classification: Fedora
Component: Democracy (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-30 12:37 EDT by Paul Ezvan
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 02:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Ezvan 2007-06-30 12:37:39 EDT
Description of problem:

democracyplayer fails to launch.
I get this error :
[paul@gen2 ~]$ democracyplayer 
/usr/lib/python2.5/site-packages/dbus_bindings.py:1: DeprecationWarning: The
dbus_bindings module is not public API and will go away soon.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 112, in
__init__
    dbus.service.Object.__init__(self, bus_name,
'/org/participatoryculture/dtv/OneTime')
  File "/usr/lib/python2.5/site-packages/dbus/service.py", line 424, in __init__
    self._connection._register_object_path(object_path, self._message_cb,
self._unregister_cb)
AttributeError: 'BusNameFlags' object has no attribute '_register_object_path'
Exception exceptions.NameError: "global name 'dbus_bindings' is not defined" in
<bound method BusNameFlags.__del__ of <dbus.service.BusName
org.participatoryculture.dtv.onetime on <dbus.Bus on SESSION at 0xb7b1074c> at
0xb7b1370c>> ignored
[paul@gen2 ~]$ democracyplayer 
/usr/lib/python2.5/site-packages/dbus_bindings.py:1: DeprecationWarning: The
dbus_bindings module is not public API and will go away soon.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 112, in
__init__
    dbus.service.Object.__init__(self, bus_name,
'/org/participatoryculture/dtv/OneTime')
  File "/usr/lib/python2.5/site-packages/dbus/service.py", line 424, in __init__
    self._connection._register_object_path(object_path, self._message_cb,
self._unregister_cb)
AttributeError: 'BusNameFlags' object has no attribute '_register_object_path'
Exception exceptions.NameError: "global name 'dbus_bindings' is not defined" in
<bound method BusNameFlags.__del__ of <dbus.service.BusName
org.participatoryculture.dtv.onetime on <dbus.Bus on SESSION at 0xb7b3b74c> at
0xb7b3e70c>> ignored


Version-Release number of selected component (if applicable):
Democracy-0.9.5.1-10.fc7

How reproducible:
Always.

Steps to Reproduce:
1.Lauch democracyplayer
2.
3.
Comment 1 Andre Robatino 2007-07-01 20:48:03 EDT
  I have the same problem on an x86 box with a fully updated clean install of F7.
Comment 2 Thorsten Scherf 2007-07-02 02:08:21 EDT

*** This bug has been marked as a duplicate of 244889 ***

Note You need to log in before you can comment on or make changes to this bug.