This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 246376 - smolt registers different language codes for Romanian language
smolt registers different language codes for Romanian language
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
http://smolt.fedoraproject.org/stats
:
Depends On: 327431 329101
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-01 05:23 EDT by Răzvan Sandu
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-14 03:24:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-07-01 05:23:43 EDT
Description of problem:

Hello,

Sorry - I know this bug is not really smolt-related, but I was unable to
correctly identify the real package where to address the bug.

If one views the statistics page at http://smolt.fedoraproject.org/stats, the
"Languages" tab, he/she may note that Romanian language appears twice: as
"ro_RO.UTF-8" and as "ro_RO.UTF_8".

This denaturates statistics about the real position of the Romanian language as
number of installations/usage.


How reproducible:
Always.

  
Actual results:
Romanian language appears twice in the statistics: as "ro_RO.UTF-8" and as
"ro_RO.UTF_8".


Expected results:
Romanian language should appear only once, as "ro_RO.UTF-8".
Comment 1 Mike McGrath 2007-07-01 10:57:47 EDT
I'd say this is a bug in python.  The code that pulls out comes from:

import os
print os.environ['LANG']


I'll take a look and see if I can combine the queries.  I'm sure the same 
issue applies to other languages as well. Here's a question for the 
translations folks.  Is there any difference (at least as far as you guys 
care) between

de_DE
de_DE.UTF-8
de_DE@euro

?
Comment 2 Dimitris Glezos 2007-07-01 12:49:56 EDT
Some points that might help:

 1. de_DE means: German of Germany. "de" by itself means German, independently
of location. Some languages (like portuguese) are different between locations,
but others (like greek) are the same.

 2. When the language is used everywhere the same, translation teams often use
just the language code (el), to denote that. However, the gettext standard is to
use the complete code (el_GR) in the system, even if the system is not in Greece.

 3. The correct encoding notation is UTF-8, not UTF_8. This shouldn't be used to
identify a language, because one might use a different encoding, yet his system
will use the same language (as an example, greek also uses el_GR.ISO-8859-7. All
these should be combined to one number (el_GR).

 3. Some language codes (like the third) define a special character set. I don'
know which application defines this strange @euro suffix, but again, it
shouldn't be considered a language differentiation.
Comment 3 Răzvan Sandu 2007-07-02 02:19:32 EDT
Hello,


Just a short note:

In RedHat-like systems, language is set in /etc/sysconfig/i18n and keyboard
layout is in /etc/sysconfig/keyboard.

I always modify the first file after installing my systems and the modification
is immediate: running smoltSendProfile „see” the modification without rebooting
the machine.

It seems that on some systems or distros /etc/sysconfig/i18n incorrectly
contains "ro_RO.UTF_8" instead of "ro_RO.UTF-8". Can someone confirm this (in
*default* configuration) ?


Regards,
Răzvan
Comment 4 Răzvan Sandu 2007-07-02 02:31:37 EDT
It seems the package that contains these national codes is iso-codes.

I think that this bug - that is not really smolt-related - must be handled by
the owner of /etc/sysconfig/i18n - am I wrong ?


Răzvan
Comment 5 Răzvan Sandu 2007-10-14 03:24:31 EDT
This seems to be a bug in anaconda - please see bug #327431.

I'm closing this now.

Regards,
Răzvan

*** This bug has been marked as a duplicate of 327431 ***

Note You need to log in before you can comment on or make changes to this bug.