Bug 329101 - anaconda puts an incorrect setting in /etc/sysconfig/i18n
anaconda puts an incorrect setting in /etc/sysconfig/i18n
Status: CLOSED DUPLICATE of bug 327431
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: 246376
  Show dependency treegraph
 
Reported: 2007-10-12 03:07 EDT by Răzvan Sandu
Modified: 2007-11-16 20:15 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 10:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-10-12 03:07:45 EDT
Hello,

Description of problem:

At least for the Romanian language, anaconda seems to put an incorrect setting
in /etc/sysconfig/i18n at installation:

LANG="ro_RO.UTF_8" (INCORRECT)

instead of

LANG="ro_RO.UTF-8" (CORRECT)

How reproducible:
Always.

Steps to Reproduce:
1. Install fresh system.
2. During installation, ask for Romanian language and keyboard.
3. At first boot in text mode, note that Romanian-specific characters in
initialization script messages are garbage.
3. After installation, view the content of /etc/sysconfig/i18n with some viewer.
  
Actual results:
Anaconda puts LANG="ro_RO.UTF_8" in /etc/sysconfig/i18n.

Expected results:
Anaconda should put LANG="ro_RO.UTF-8" in /etc/sysconfig/i18n.

Regards,
Răzvan
Comment 1 Chris Lumens 2007-10-12 10:15:32 EDT

*** This bug has been marked as a duplicate of 327431 ***

Note You need to log in before you can comment on or make changes to this bug.