Bug 246382 - GNUCash (64bit) will not run
GNUCash (64bit) will not run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 251867 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-01 10:59 EDT by Gantry York
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.2.1-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 13:07:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/install.log (74.01 KB, text/plain)
2007-07-17 02:17 EDT, Tomasz Kepczynski
no flags Details
/var/log/anaconda.log (32.98 KB, text/plain)
2007-07-17 02:18 EDT, Tomasz Kepczynski
no flags Details

  None (edit)
Description Gantry York 2007-07-01 10:59:02 EDT
Description of problem:

With Fedora64-7, GNUCash will not run.  It appears to be a 64/32 bit shared
library problem.

Try to run it and it (from the command line) and it results in the following
error message.

gnucash-bin: error while loading shared libraries: libgncmod-engine.so.0: wrong
ELF class: ELFCLASS32


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2007-07-02 12:28:20 EDT
What does 'rpm -q --qf "%{NAME}.%{ARCH}\n" gnucash' say?
Comment 2 Tomasz Kepczynski 2007-07-09 09:42:36 EDT
I have the same problem but only when both gnucash.x86_64
and gnucash.i386 are installed. Removing both and installing
gnucash.x86_64 resolves the problem.
For me it looks like /usr/bin/gnucash is overwritten by
32 bit version.
The problem is easily reproducible by:
# yum remove gnucash
# rpm -ivh path_to_gnucash.x86_64
# rpm -ivh --force path_to_gnucash.i386
Check then /usr/bin/gnucash and see that library paths refer
to /usr/lib and not /usr/lib64.
yum and rpm seem to prevent this problem (they seem to install
in correct order when providing both packages in one command
line and refuse to install i386 over x86_64), so probably
anaconda got it wrong somehow during install.
Comment 3 Bill Nottingham 2007-07-09 14:06:48 EDT
Hrm, there's really no reason that should be multilib. Investigating....
Comment 4 Bill Nottingham 2007-07-09 14:41:16 EDT
Actually, I see why it's multilib. Why are you installing i386 with --force? How
did it get installed to begin with?
Comment 5 Tomasz Kepczynski 2007-07-09 15:29:55 EDT
Actually I have 2 machines where it was installed. On one of them
it was installed using kickstart with the following repos defined:
repo --name=updates --baseurl=file:///tmp/repos/updates/7/x86_64/
repo --name=everything --baseurl=file:///tmp/repos/releases/7/Everything/x86_64/os/
%pre --log=/root/pre.log
[[ -d /tmp/mnt ]] || mkdir /tmp/mnt
mount -r 172.28.59.1:/srv/nfs/install /tmp/mnt
cp /tmp/mnt/linux/Fedora/ks/7/{wks-rpm-list.txt,std-post.sh} /tmp
umount /tmp/mnt
[[ -d /tmp/repos ]] || mkdir /tmp/repos
mount -r 172.28.59.1:/srv/nfs/install/linux/Fedora /tmp/repos
I am quite (but not 100%) sure that the other machine was setup
the same way (server addresses and paths might be different).
and gnucash listed in the file included as below:
%packages --ignoremissing
%include /tmp/wks-rpm-list.txt
where wks-rpm-list.txt contains line with gnucash alone.
Comment 6 Tomasz Kepczynski 2007-07-09 15:31:55 EDT
Forgot about --force in #2 above. It is needed because rpm/yum
complains about some conflicting files and refuses to install
package.
Comment 7 Bill Nottingham 2007-07-09 15:45:07 EDT
If you remove both versions, and install the i386 and x86_64 RPMs in the same
transaction, which /usr/bin/gnucash do you get?
Comment 8 Tomasz Kepczynski 2007-07-09 15:47:20 EDT
The correct one (with references to 64-bit libraries). But I've only
tried it once or twice for both rpm and yum.
Comment 9 Bill Nottingham 2007-07-09 16:53:35 EDT
So, the issue is if there is a 'normal' code path (not --force) to install the
32-bit one and actually get /usr/bin/gnucash. I'm not sure off the top of my
head how that would happen.
Comment 10 Tomasz Kepczynski 2007-07-09 17:21:07 EDT
Yes. And as I mentioned I am quite sure this happend during
kickstart install. I can provide all the files I used if
needed.
Or maybe bug submitter has any idea what happend in his case?
Comment 11 Bill Nottingham 2007-07-09 17:23:34 EDT
Pushing to anaconda, then.
Comment 12 Gantry York 2007-07-12 20:32:49 EDT
Sorry I haven't responded.  For some reason, I'm not receiving email updates.

Anyway, I installed GNUCash using pirut after a full-wipe-the-disk-clean
install.  I did not --force the install.

[root@yosemite ~]# rpm -q --qf "%{NAME}.%{ARCH}\n" gnucash
gnucash.x86_64
gnucash.i386



Comment 13 Gantry York 2007-07-12 20:55:20 EDT
Is it really necessary to have both the i386 and x86_64 versions installed?  

And is my problem solved if I simply install the i386 version, then the x86_64
version in that order?
Comment 14 Tomasz Kepczynski 2007-07-13 00:41:04 EDT
(In reply to comment #13)
> Is it really necessary to have both the i386 and x86_64 versions installed?  
I do't know but for me it looks like it is not needed.

> And is my problem solved if I simply install the i386 version, then the x86_64
> version in that order?
This will not work. Just try:
# yum install gnucash
after removing it first, it should be ok. Or just install x86_64 version:
# yum install gnucash.x86_64

Comment 15 Bill Nottingham 2007-07-13 09:46:07 EDT
You don't need both arches ; one or the other should suffice. But there's an
underlying issue somewhere, as having them both installed should *not* break things.
Comment 16 Jeremy Katz 2007-07-16 16:26:23 EDT
Can you attach the /root/install.log and /var/log/anaconda.log?
Comment 17 Tomasz Kepczynski 2007-07-17 02:17:08 EDT
Created attachment 159406 [details]
/root/install.log

This shows that gnucash.x86_64 is installed _before_
gnucash.i386 which may be problematic.
Comment 18 Tomasz Kepczynski 2007-07-17 02:18:11 EDT
Created attachment 159407 [details]
/var/log/anaconda.log
Comment 19 Bill Nottingham 2007-08-31 13:50:25 EDT
*** Bug 251867 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2007-11-09 18:55:46 EST
gnucash-2.2.1-4.fc7, gnucash-docs-2.2.0-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnucash gnucash-docs'
Comment 21 Fedora Update System 2007-11-20 13:07:01 EST
gnucash-2.2.1-4.fc7, gnucash-docs-2.2.0-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.