Bug 251867 - gnucash cannot find libgncmod-engine.so
gnucash cannot find libgncmod-engine.so
Status: CLOSED DUPLICATE of bug 246382
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-12 17:47 EDT by Joel Uckelman
Modified: 2014-03-16 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 13:50:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Uckelman 2007-08-12 17:47:06 EDT
Description of problem:

gnucash fails to start due to a shared-library problem.

Version-Release number of selected component (if applicable):

gnucash-2.2.0-1.fc7


How reproducible:

Always.

Steps to Reproduce:
1. Run gnucash from a terminal.
  
Actual results:

[uckelman@localhost ~]$ gnucash
gnucash-bin: error while loading shared libraries: libgncmod-engine.so: cannot
open shared object file: No such file or directory

Expected results:

gnucash should start.


Additional info:

The requested library, libgncmod-engine.so, does exist on my system, in
/usr/lib64/gnucash.
Comment 1 Bill Nottingham 2007-08-12 23:29:54 EDT
What does 'rpm -q --qf %{ARCH}\n gnucash ' say?
Comment 2 Joel Uckelman 2007-08-13 05:36:46 EDT
I get:

x86_64n

(probably need to quote '%{ARCH}\n' to get the \n to be a newline, heh)

I had the i386 package installed along side the x86_64 one; the same thing
happened when I started gnucash then, as well.
Comment 3 Bill Nottingham 2007-08-29 13:21:24 EDT
Does it verify correctly?
Comment 4 Joel Uckelman 2007-08-31 06:08:35 EDT
Here's the relevant output from 'rpm -V gnucash':

S.5....T /usr/bin/gnc-fq-check
S.5....T /usr/bin/gnc-fq-helper
S.5....T /usr/bin/gnc-fq/update
S.5....T /usr/bin/gnucash
S.5....T /usr/bin/gnucash-valgrind
S.5....T /usr/libexec/gnucash/overrides/gnucash-env

Just to be safe, I uninstalled gnucash and gnucash-doc, and then reinstalled
them. , after which verify produced the same results. I guess the size and MD5
differ on these because of prelinking?

After reinstalling I was able to run gnucash. I can't fathom why it worked after
the second reinstall but not after the first. I do now get the following warning
on starting gnucash, though:

gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

Anyway, the problem is gone for me now, though I would like to know what caused it.
Comment 5 Bill Nottingham 2007-08-31 13:50:24 EDT
Assigning as a dup of what appears to be the same problem.

*** This bug has been marked as a duplicate of 246382 ***

Note You need to log in before you can comment on or make changes to this bug.