Bug 246441 - can not specify the type of driver device
can not specify the type of driver device
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 246440 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-02 05:15 EDT by Saori Fukuta
Modified: 2008-02-20 23:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 16:24:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
added the option (4.41 KB, patch)
2007-07-02 05:15 EDT, Saori Fukuta
no flags Details | Diff

  None (edit)
Description Saori Fukuta 2007-07-02 05:15:05 EDT
Description of problem:
  I would like to set the type of driver device(aio/sync ...etc),
  when I install the guest domain.
  But there is no option on virt-install, so I can not specify any 
  type.

Version-Release number of selected component (if applicable):
  virtinst 0.103.0(changeset 205)

How reproducible:
  always

Steps to Reproduce:
  1.install the guest domain
  # virt-install ...
  
Actual results:
  We can not specify the type of driver device.

Expected results:
  We can specify the type of driver device.

Additional info:
  I attached the patch that I added the option to choose the
  type of driver device.

  virt-install help:
  --drvtype=DRVTYPE     Type of driver device, e.g. 'aio', 'qcow', 'vmdk',
                        'sync'
Comment 1 Saori Fukuta 2007-07-02 05:15:05 EDT
Created attachment 158326 [details]
added the option
Comment 2 Cole Robinson 2007-11-30 16:30:49 EST
Having driver as a command line option seems useful, but virt-install prompting
the user for a driver on a "guided" install is not the best idea: the info is
not needed as we can choose a working default, and it is probably too advanced
for most people using the guided install.

Could you remove that portion of the patch, and post it to
et-mgmt-tools@redhat.com for a wider audience? Thanks!
Comment 3 Saori Fukuta 2007-12-02 19:26:04 EST
Many thanks for reviewing this BZ.
I had already posted it, and I understood the option which I added was not 
really useful option, because its only used by Xen paravirt.
c.f. the thread at:
   https://www.redhat.com/archives/et-mgmt-tools/2007-July/msg00001.html
And, it will be too advanced for installing as you said.

So, could you close this BZ ?

Thanks,
Saori Fukuta
Comment 4 Cole Robinson 2007-12-04 16:24:08 EST
Ah sorry, must have missed when that patch came by on the list. Thanks for the
pointer, closing this as WONTFIX.
Comment 5 Matt Domsch 2008-02-20 23:38:37 EST
*** Bug 246440 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.