Bug 246462 - Badness at kernel/softirq.c:138
Summary: Badness at kernel/softirq.c:138
Status: CLOSED DUPLICATE of bug 240982
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: powerpc Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-02 14:21 UTC by Robert Story
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-05 20:55:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Story 2007-07-02 14:21:14 UTC
Description of problem:
While perusing syslog for traces of an unrelated crash, I came across this log
message:

  kernel: Badness at kernel/softirq.c:138

I don't recall having any particular problems... reporting in case stack traces
help maintainers..


Version-Release number of selected component (if applicable):
2.6.21-1.3194.fc7

How reproducible:
Unknown

Steps to Reproduce:
1. unknown
  
Actual results:


Expected results:


Additional info:

Jun 15 10:22:53 spx kernel: ------------[ cut here ]------------
Jun 15 10:22:53 spx kernel: Badness at kernel/softirq.c:138
Jun 15 10:22:53 spx kernel: Call Trace:
Jun 15 10:22:53 spx kernel: [EA957BD0] [C0008AB0] show_stack+0x50/0x184 (unreliable)
Jun 15 10:22:53 spx kernel: [EA957BF0] [C012072C] report_bug+0x84/0xc8
Jun 15 10:22:53 spx kernel: [EA957C00] [C02B1A2C] __kprobes_text_start+0x154/0x538
Jun 15 10:22:53 spx kernel: [EA957C50] [C0013280] ret_from_except_full+0x0/0x4c
Jun 15 10:22:53 spx kernel: --- Exception: 700 at local_bh_enable+0x28/0x8c
Jun 15 10:22:53 spx kernel:     LR = cond_resched_softirq+0x58/0x80
Jun 15 10:22:53 spx kernel: [EA957D10] [84022488] 0x84022488 (unreliable)
Jun 15 10:22:53 spx kernel: [EA957D20] [C02B0344] cond_resched_softirq+0x58/0x80
Jun 15 10:22:53 spx kernel: [EA957D30] [C0231D30] release_sock+0x54/0xac
Jun 15 10:22:53 spx kernel: [EA957D50] [C0269B20] tcp_sendmsg+0xac0/0xbf8
Jun 15 10:22:53 spx kernel: [EA957DB0] [C028666C] inet_sendmsg+0x60/0x74
Jun 15 10:22:53 spx kernel: [EA957DD0] [C022ED68] sock_aio_write+0x114/0x130
Jun 15 10:22:53 spx kernel: [EA957E30] [C008FF38] do_sync_write+0xb8/0x10c
Jun 15 10:22:53 spx kernel: [EA957EF0] [C0090B10] vfs_write+0x104/0x1c8
Jun 15 10:22:53 spx kernel: [EA957F10] [C00911AC] sys_write+0x4c/0x8c
Jun 15 10:22:53 spx kernel: [EA957F40] [C0012C24] ret_from_syscall+0x0/0x38
Jun 15 10:22:53 spx kernel: --- Exception: c00 at 0xf14f0bc
Jun 15 10:22:53 spx kernel:     LR = 0xf14f0a4
[...]
Jun 15 12:04:51 spx kernel: ------------[ cut here ]------------
Jun 15 12:04:51 spx kernel: Badness at kernel/softirq.c:138
Jun 15 12:04:51 spx kernel: Call Trace:
Jun 15 12:04:51 spx kernel: [EAA9FB30] [C0008AB0] show_stack+0x50/0x184 (unreliable)
Jun 15 12:04:51 spx kernel: [EAA9FB50] [C012072C] report_bug+0x84/0xc8
Jun 15 12:04:51 spx kernel: [EAA9FB60] [C02B1A2C] __kprobes_text_start+0x154/0x538
Jun 15 12:04:51 spx kernel: [EAA9FBB0] [C0013280] ret_from_except_full+0x0/0x4c
Jun 15 12:04:51 spx kernel: --- Exception: 700 at local_bh_enable+0x28/0x8c
Jun 15 12:04:51 spx kernel:     LR = cond_resched_softirq+0x58/0x80
Jun 15 12:04:51 spx kernel: [EAA9FC70] [24042488] 0x24042488 (unreliable)
Jun 15 12:04:51 spx kernel: [EAA9FC80] [C02B0344] cond_resched_softirq+0x58/0x80
Jun 15 12:04:51 spx kernel: [EAA9FC90] [C0231D30] release_sock+0x54/0xac
Jun 15 12:04:51 spx kernel: [EAA9FCB0] [C0269B20] tcp_sendmsg+0xac0/0xbf8
Jun 15 12:04:51 spx kernel: [EAA9FD10] [C028666C] inet_sendmsg+0x60/0x74
Jun 15 12:04:51 spx kernel: [EAA9FD30] [C022FBCC] sock_sendmsg+0xd0/0x100
Jun 15 12:04:51 spx kernel: [EAA9FE20] [C0230F7C] sys_sendto+0xe0/0x110
Jun 15 12:04:51 spx kernel: [EAA9FF00] [C02312A0] sys_socketcall+0x148/0x1fc
Jun 15 12:04:51 spx kernel: [EAA9FF40] [C0012C24] ret_from_syscall+0x0/0x38
Jun 15 12:04:51 spx kernel: --- Exception: c00 at 0xf14f6ac
Jun 15 12:04:51 spx kernel:     LR = 0xf14f698

Comment 1 Chuck Ebbert 2007-07-05 20:55:19 UTC

*** This bug has been marked as a duplicate of 240982 ***


Note You need to log in before you can comment on or make changes to this bug.