Bug 246516 - lstat failed errors - .cache contains invalid items
Summary: lstat failed errors - .cache contains invalid items
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Milan Broz
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords: Regression
: 248814 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-02 19:33 UTC by Corey Marthaler
Modified: 2013-03-01 04:05 UTC (History)
6 users (show)

Fixed In Version: RHBA-2007-0516
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 16:49:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvmdump before the creation (52.99 KB, application/x-gzip)
2007-07-02 19:35 UTC, Corey Marthaler
no flags Details
lvmdump after the creation (53.94 KB, application/x-gzip)
2007-07-02 19:35 UTC, Corey Marthaler
no flags Details
verbose -vvvv output from creation (93.92 KB, text/plain)
2007-07-02 19:37 UTC, Corey Marthaler
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0516 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2007-10-30 16:18:33 UTC

Description Corey Marthaler 2007-07-02 19:33:00 UTC
Description of problem:
During lvm regression testing there is a test case that attempts to create 32
mirrors all with the names "thirty_[1-32]" and lately whenever I attempt to
create a mirror with that name I get a "lstat failed" error even though the
creation works.  If I try a different name, I don't see the error. I didn't
notice any left over entries in the device-mapper listings and I have deleted
both the lvm/backup and lvm/archive directories.

lvcreate -m 1 -n thirty_1 -vvvv -L 100M mirror_sanity

  /dev/mirror_sanity/thirty_1_mlog: lstat failed: No such file or directory
  Logical volume "thirty_1" created


Version-Release number of selected component (if applicable):
2.6.18-27.el5
lvm2-2.02.26-1.el5

How reproducible:
everytime

Comment 1 Corey Marthaler 2007-07-02 19:35:21 UTC
Created attachment 158368 [details]
lvmdump before the creation

Comment 2 Corey Marthaler 2007-07-02 19:35:57 UTC
Created attachment 158369 [details]
lvmdump after the creation

Comment 3 Corey Marthaler 2007-07-02 19:37:49 UTC
Created attachment 158370 [details]
verbose -vvvv output from creation

Comment 4 Milan Broz 2007-07-02 19:50:53 UTC
There are invalid devices left in /etc/lvm/cache/.cache file, removing .cache helps.


Comment 5 Milan Broz 2007-07-09 15:55:20 UTC
I see this on RHEL4 too when using lvconvert on mirror and converting from core
log to disk log (even if .cache is removed before this operation).
(But it is seems that problem is in .cache use anyway.)


Comment 6 Milan Broz 2007-07-19 17:47:42 UTC
*** Bug 248814 has been marked as a duplicate of this bug. ***

Comment 9 Milan Broz 2007-08-09 08:45:43 UTC
Fixed in lvm2-2.02.26-3.el5.

Comment 11 Corey Marthaler 2007-09-27 20:11:24 UTC
This bug has been verified fixed in lvm2-2.02.27-2.el4.

Comment 12 Corey Marthaler 2007-09-27 20:33:12 UTC
whoops, wrong machine, fix was verified in lvm2-2.02.26-3.el5.

Comment 14 errata-xmlrpc 2007-11-07 16:49:19 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0516.html



Note You need to log in before you can comment on or make changes to this bug.