Bug 248814 - lstat failure errors when renaming snapshot volumes
Summary: lstat failure errors when renaming snapshot volumes
Status: CLOSED DUPLICATE of bug 246516
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Milan Broz
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-18 22:42 UTC by Corey Marthaler
Modified: 2013-03-01 04:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 17:47:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Marthaler 2007-07-18 22:42:33 UTC
Description of problem:
This appears to be a regression. It's not in rhel4u5.

[root@taft-04 ~]# lvrename /dev/snapper/rename_snapA /dev/snapper/rename_snapB
  Renamed "rename_snapA" to "rename_snapB" in volume group "snapper"
  /dev/snapper/rename_snapA: lstat failed: No such file or directory
  /dev/mapper/snapper-rename_snapA-cow: lstat failed: No such file or directory

[root@taft-04 ~]# lvrename /dev/snapper/rename_snapB /dev/snapper/rename_snapA
  Renamed "rename_snapB" to "rename_snapA" in volume group "snapper"
  /dev/mapper/snapper-rename_snapB-cow: lstat failed: No such file or directory
  /dev/snapper/rename_snapB: lstat failed: No such file or directory

[root@taft-04 ~]# echo $?
0


Version-Release number of selected component (if applicable):
lvm2-2.02.26-1.el5
2.6.18-32.el5

How reproducible:
everytime

Comment 1 Milan Broz 2007-07-19 12:58:18 UTC
Probably regression, I see this using upstream package too if using text
metadata format:
/etc/lvm/metadata/vg_test.tmp: stat failed: No such file or directory


Comment 2 Milan Broz 2007-07-19 17:47:39 UTC
Comment #1 is nonsense.

Found source of problem, we have already bug for it.


*** This bug has been marked as a duplicate of 246516 ***


Note You need to log in before you can comment on or make changes to this bug.