Bug 246542 - anaconda bails out with "PackageSackError: No Package Matching kernel.i686"
anaconda bails out with "PackageSackError: No Package Matching kernel.i686"
Status: CLOSED DUPLICATE of bug 244376
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-02 18:53 EDT by Michal Jaegermann
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 22:22:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda produced report (160.55 KB, text/plain)
2007-07-02 18:53 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-07-02 18:53:48 EDT
Description of problem:

I tried to upgrade a system running FC4 to F7.  anaconda worked
for a while and eventually ended up with the following:

Traceback (most recent call first):
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 600, in
returnNewestByNameArch
    raise PackageSackError, 'No Package Matching %s.%s' % naTup
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 308, in
returnNewestByNameArch
    return bestofeach.returnNewestByNameArch(naTup)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 662, in
_processConflict
    po = self.pkgSack.returnNewestByNameArch((confpkg.name,confpkg.arch))[0]
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 856, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processConflict(dep)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 549, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/anaconda/yuminstall.py", line 1016, in doPostSelection
    (code, msgs) = self.ayum.buildTransaction()
  File "/usr/lib/anaconda/backend.py", line 227, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 203, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1041, in nextClicked
    self.anaconda.dispatch.gotoNext()
PackageSackError: No Package Matching kernel.i686

The system was upgradable; only the above forced me into quite
a bit of "manual" work (although some pieces were later done
with a help of anaconda).

Full 161K of what anaconda produced on that traceback is attached.
Comment 1 Michal Jaegermann 2007-07-02 18:53:48 EDT
Created attachment 158386 [details]
anaconda produced report
Comment 2 Chris Lumens 2007-07-11 22:22:49 EDT

*** This bug has been marked as a duplicate of 244376 ***

Note You need to log in before you can comment on or make changes to this bug.