Bug 244376 - unhandled exception upon upgrade of Fedora Core 4 to Fedora 7
Summary: unhandled exception upon upgrade of Fedora Core 4 to Fedora 7
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
urgent
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
: 246542 247230 247925 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-15 10:29 UTC by Christian SCHLATTER
Modified: 2007-11-30 22:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 21:45:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump of unhandled exception (168.05 KB, text/plain)
2007-06-15 10:29 UTC, Christian SCHLATTER
no flags Details

Description Christian SCHLATTER 2007-06-15 10:29:47 UTC
Description of problem:
I want to upgrade my Fedora Core 4 installation to Fedora 7 using the bootable
DVD. After configuration of the boot options, anaconda starts to look for
package dependencies and stops with an unhandled exception.

Comment 1 Christian SCHLATTER 2007-06-15 10:29:47 UTC
Created attachment 157087 [details]
dump of unhandled exception

Comment 2 David Johnson 2007-07-07 18:34:06 UTC
Same thing trying to upgrade from Fedora Core 5 to Fedora 7.

Exception logged to floppy: attached

Comment 3 Chris Lumens 2007-07-12 02:20:21 UTC
*** Bug 247925 has been marked as a duplicate of this bug. ***

Comment 4 Chris Lumens 2007-07-12 02:21:32 UTC
*** Bug 247230 has been marked as a duplicate of this bug. ***

Comment 5 Chris Lumens 2007-07-12 02:22:52 UTC
*** Bug 246542 has been marked as a duplicate of this bug. ***

Comment 6 George Anzinger 2007-07-12 20:24:09 UTC
I too have this same problem trying to upgrade from fc3 to f7.  All these
reports seem to be tied to kernel.i686.  Since mine stopped in the "resolve
dependencies" area, I assume that is true of all occurrences, given that the
trace back looks almost identical.

A work around would be most welcome.

Comment 7 George Anzinger 2007-07-24 01:34:01 UTC
I don't know if this work for all of these but, I got the update to work by
using rpm to remove all the kernels save the one I actually was booting.  Do:
rpm -q kernel

then rpm -e kernelxxx where the xxx is the kernel to remove.  Do NOT remove the
one grup is booting (look in the grup.conf file in /boot/grub/ or some such).

Comment 8 David Cantrell 2007-09-11 21:45:53 UTC
Upgrades are supported from the previous release to the current release, not
from a far back release to the current one.


Note You need to log in before you can comment on or make changes to this bug.