Bug 246567 - ls colour display corrupt for symbolic links
ls colour display corrupt for symbolic links
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 01:03 EDT by Karl Czajkowski
Modified: 2007-12-06 17:53 EST (History)
0 users

See Also:
Fixed In Version: 6.9-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 17:53:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karl Czajkowski 2007-07-03 01:03:48 EDT
Description of problem:

Symbolic links are not listed properly when colouring is enabled for directory
listings containing symbolic link children.

Version-Release number of selected component (if applicable):

coreutils-6.9-3.fc7

How reproducible:

Always.

Steps to Reproduce:
1. create a symbolic link such as /home/user -> ../../etc/hosts
2. cd /home/user
3. /bin/ls --color=always | grep hosts
  
Actual results:

host::karlcz[~] /bin/ls --color=always | grep hosts
argetmhosts


Expected results:

host::karlcz[~] /bin/ls --color=always | grep hosts
hosts

Additional info:

The corruption does not appear in long listings, nor when the file is listed
explicitly, nor when coloring is disabled:

host::karlcz[~] /bin/ls --color=always hosts
hosts

host::karlcz[~] /bin/ls --color=always -l | grep hosts
lrwxrwxrwx  1 karlcz karlcz       15 2007-07-03 11:48 hosts -> ../../etc/hosts

host::karlcz[~] /bin/ls --color=never | grep hosts
hosts
Comment 1 Ondrej Vasik 2007-12-05 07:02:45 EST
Sorry for delay, but got maintaining of coreutils in October and there were
other issues to be solved, could not reproduce with coreutils-6.9-5.fc7 and
xterm - what is your TERM setting? 
Comment 2 Karl Czajkowski 2007-12-05 08:08:24 EST
I am using TERM=xterm and the regular xterm program.  It happens with LANG=C and
LANG=en_US.UTF-8 and I did not try any other LANG settings...

I just verified that this still occurs for me with coreutils-6.9.5.fc7 on an
up-to-date Fedora 7 i686 install. It does not occur on an equivalent Fedora 8
machine I have with coreutils-6.9-11.fc8...

Here are a few other environment values from the system where it fails, in case
this is helpful...

TERM=xterm
SHELL=/bin/bash
LS_COLORS=no=00:fi=00:di=37:ln=target:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=
40;33;01:or=33;101:ex=31:*.tar=35:*.gz=93:*.tar.gz=35:*.tgz=35:*.arj=35:*.taz=35
:*.lzh=35:*.zip=35:*.z=93:*.Z=93:*.bz2=93:*.deb=35:*.rpm=35:*.jpg=32:*.png=32:*.
gif=32:*.bmp=32:*.ppm=32:*.tga=32:*.xbm=32:*.xpm=32:*.tif=32:*.png=32:*.mpg=32:*
.avi=32:*.fli=32:*.gl=32:*.dl=32:*.pnm=32:*.ppm=32:*.pgm=32:*.pbm=32:*.pdf=33:*.
ps=33:*.txt=36:*.html=36:*.htm=36:*.doc=33:*.ppt=33:*.h=33:*.o=91:*.c=33:*.cc=33
:*.C=33:*.c++=33:*.cxx=33:
INPUTRC=/etc/inputrc
LANG=en_US.UTF-8
G_BROKEN_FILENAMES=1
Comment 3 Ondrej Vasik 2007-12-05 09:00:35 EST
Ok, I will backport coreutils bugfixes from F8 to F7(there is one relevant for
ls and displaying symlinks - but it worked for me even with current version on
my machine - strange) and we will see. Built as coreutils-6.9.6.fc7, will get
closed automatically once it will get pushed to F7 stable, feel free to reopen
it if the bug will be still present after update.
Comment 4 Fedora Update System 2007-12-06 17:53:17 EST
coreutils-6.9-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.