Bug 246637 - udev no longer creates /dev/pilot symlinks for Palm devices
udev no longer creates /dev/pilot symlinks for Palm devices
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
: 250948 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 11:53 EDT by Jesse Keating
Modified: 2013-01-09 21:36 EST (History)
6 users (show)

See Also:
Fixed In Version: pilot-link-0.12.2-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 06:03:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-07-03 11:53:41 EDT
It's expected that a /dev/pilot symlink is created for palm devices, so that
pam.console rules can set ownership correctly and things like gnome-pilot are
able to sync correctly.

A had to add a custom rule:
SYSFS{idVendor}=="0830", SYSFS{idProduct}=="0061", SYMLINK+="pilot"

but that just covers my Treo.  This is a regression from previous releases.
Comment 1 Harald Hoyer 2007-07-04 06:15:09 EDT
you may change SYSFS to ATTRS.. does that help?
Comment 2 Jesse Keating 2007-07-04 22:41:25 EDT
Hrm, maybe I'm not clear.  When I add the above custom rule things work just
fine.  Without the rule I never get the /dev/pilot device nor do I get correct
permissions to the /dev/ttyUSB0/1.
Comment 3 Harald Hoyer 2007-07-05 06:40:10 EDT
pilot rules removed due to complexity... udev cannot know which of the two
devices a palm can provide is the correct line.

pilot-link should have some logic about this..
Comment 4 Craig White 2007-07-18 15:49:38 EDT
creating /etc/udev/rules/60-libpisock.rules

KERNEL=="ttyUSB*", SYSFS{idVendor}=="0830", SYSFS{idProduct}=="0061",
SYMLINK+="pilot", GROUP="uucp", MODE="0664"

per above worked for me with Palm T|X
Comment 5 Karl F. Larsen 2007-07-18 17:20:13 EDT
All this above is Greek to me. I have a Palm Z22 which worked fine on FC6 but
fails to do anything on F7. I hoped the experts could see what changed and
understand why.

As far as I know all Palm PDA's fail when used with F7.

Karl Larsen
Comment 6 Andrea Dell'Amico 2007-08-20 21:01:19 EDT
(In reply to comment #3)
> pilot rules removed due to complexity... udev cannot know which of the two
> devices a palm can provide is the correct line.
> 
> pilot-link should have some logic about this..

With the latest pilot-link package, if I create the file
/etc/udev/rules.d/60-libpisock.rules as in "README.libusb" (from the pilot-link
distribution, not installed by the pilot-link package), add to every entry
'SYMLINK+="pilot"' and then choose 'usb:' as the device, it works well every
time I try to sync or install some software.

There is a strange behaviour, still: a popup from gnome-pilot states that the
visor module should not be loaded when libusb is used but that's not the case
for me.

Note: the popup appeared while I was experimenting with the udev rules and the
connection with my palm failed.

Hope it helps
Comment 7 Ivana Varekova 2007-08-23 06:03:57 EDT
The last fc7 version of pilot-link package
(pilot-link-0.12.2-4.fc7) fixes these problem.
Comment 8 Ivana Varekova 2007-08-23 06:42:05 EDT
*** Bug 250948 has been marked as a duplicate of this bug. ***
Comment 9 Andrea Dell'Amico 2007-08-23 06:57:06 EDT
(In reply to comment #7)
> The last fc7 version of pilot-link package
> (pilot-link-0.12.2-4.fc7) fixes these problem.

With that package I still needed the udev rules when I tried, see comment #6.
I'll check again tonight.
Comment 10 Andrea Dell'Amico 2007-08-24 07:57:14 EDT
I can confirm that also with package pilot-link-0.12.2-4.fc7 I still need the
udev rules to sync my treo 650.
Without the rules, gnome-pilot says that it cannot connect to the device via
libusb even if I selected the 'usb:' device, because the visor module is loaded.

I blacklisted the 'visor' kernel module too, but with the only effect to have
the treo not recognized anymore.

Comment 11 Karl F. Larsen 2007-10-02 15:01:19 EDT
Well I just tried my Z22 on my F7 fully updated and it failed to make contact. I
tried both ways saying it had worked and no never worked. It just was impossible
to connect. My Palm says connection between this palm and your computer could
not be made. 

Of course it works fine on Windows, and worked on FC6.

Note You need to log in before you can comment on or make changes to this bug.