Bug 246679 - gdb info incorrectly lists "libbfd" as a prerequisite.
gdb info incorrectly lists "libbfd" as a prerequisite.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 18:05 EDT by Robert P. J. Day
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 21:54:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert P. J. Day 2007-07-03 18:05:27 EDT
the gdb info "Contributors" page reads:

"GDB uses the BFD subroutine library to examine multiple object-file
formats; BFD was a joint project of David V.  Henkel-Wallace, Rich
Pixley, Steve Chamberlain, and John Gilmore."

  i don't think gdb uses the BFD libs anymore.  those libs are part of the
binutils-devel package, which are not a prereq of gdb, as far as i can tell.
Comment 1 Jan Kratochvil 2007-07-03 21:54:40 EDT
gdb-X-Y.src.rpm contains gdb-X.Y.tar.bz2 which contains gdb-X.y/bfd subdirectory
containing the BFD library.
GDB functionality is based on the BFD library.
Due to a complicated API/ABI compatibility of BFD it is bundled with each
package separately - both with GDB and with BINUTILS.
It is built statically with GDB so you do not see it even by ldd(1).

Note You need to log in before you can comment on or make changes to this bug.