Bug 2467 - Installer not recognizing Tulip NIC Cards
Installer not recognizing Tulip NIC Cards
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-01 13:46 EDT by ken
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-24 11:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ken 1999-05-01 13:46:01 EDT
Durring the install for setting up the networking, choosing
the option for Tulip, then probing, driver can not find the
NIC.
Manual setup after the install, card is accessed fine.
Comment 1 Dale Lovelace 1999-06-04 16:04:59 EDT
What brand on NIC is this? There are several cards based on the Tulip
chipset.
Comment 2 Jay Turner 1999-06-30 12:55:59 EDT
Discarded due to lack of response.
Comment 3 nagel 1999-09-21 11:49:59 EDT
I've had this problem as well. The card is a D-Link 530CT. The chip is
a DEC 21041. This problem may have something to do with bug #2582 but
I'm not sure.
Comment 4 David Lawrence 1999-09-22 18:12:59 EDT
Just make sure that the Reopen bug choice is selected and click on
Commit.
Comment 5 Bill Nottingham 1999-09-22 19:52:59 EDT
What does 'lspci -v' say your card is?
(alternatively, 'cat /proc/pci')
Comment 6 nagel 1999-09-24 10:54:59 EDT
I tried to install again last night and this is what I found. While
the install was going I switched over to vc2 and did a cat /proc/pci.
These are the bus and ethernet card entries. I left out the video card
and ide interface.

PCI devices found:
 Bus 0, device 0, Function 0:
   Host bridge: VIA Technologies VT 82C576 3V (rev 2)
   Fast devsel. Master Capable. No bursts.

 Bus 0, device 10, Function 0:
   Ethernet controller: DEC DC21041 (rev 33).
   Medium devsel. Fast back-to-back capable. Master Capable.
Latency=32.
   I/O at 0x6100 [0x6100].
   Non-prefetchable 32 bit memory at 0xf0800000 [0xf0800000].

This machine is a P150. I have another machine at work which uses the
same card and it was detected just fine by the installer. Here's it's
pci info.

PII 350MHz
 PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: Intel 440BX - 82443BX Host (rev 2).
      Medium devsel.  Master Capable.  Latency=64.
      Prefetchable 32 bit memory at 0xe0000000 [0xe0000008].
  Bus  0, device   1, function  0:
    PCI bridge: Intel 440BX - 82443BX AGP (rev 2).
      Medium devsel.  Master Capable.  Latency=64.  Min Gnt=136.

  Bus  0, device  13, function  0:
    Ethernet controller: DEC DC21041 (rev 33).
      Medium devsel.  Fast back-to-back capable.  IRQ 11.  Master
Capable.  Latency=64.
      I/O at 0x6800 [0x6801].
      Non-prefetchable 32 bit memory at 0xe9000000 [0xe9000000].

Anyway... during the install I was jumping around between vc's and saw
some interesting things. Here is what it said when it detected the
etherenet card.

VC3
*pci probing for ethernet devices
*pci probe found 1 ethernet devices
*found driver for Digital 21040 (Tulip)
*picked driver Digital 21040 (Tulip)
*running: /bin/insmod /bin/insmod /modules/tulip.o
*insmod failed!

I think we found the problem. insmod also fails to load
/modules/loop0.o. The install fails to create a boot floppy and
install the bootloader because it can't access /dev/loop0.

One more thing. I didn't pay much attention to VC4 but I did manage to
see something that might be useful.

VC4
<6>install uses obsolete /proc/pci interface

I don't know what step this was from. Sorry. Hope all this info helps
track down the problem.
Comment 7 Bill Nottingham 1999-09-24 11:58:59 EDT
That shouldn't be a problem. It looks like you're using
a boot disk with a different kernel than the modules
on the install image; if so, make sure you boot with
'linux supp'.

Note You need to log in before you can comment on or make changes to this bug.