Bug 24670 - XFree86 Server 4.0 for SIS620 doesn't work.
XFree86 Server 4.0 for SIS620 doesn't work.
Status: CLOSED DUPLICATE of bug 19530
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-22 23:17 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 15:56:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-22 23:17:47 EST
I have a sis620 video card in a pcchips 748MR main board. XFree86 4.0.1 
server for sis displays fonts abnormally, and easily drives monitor into 
dead state. The console message complain "unresolved symbol memcpy in 
module sis_drv.o". I found that only sis_drv.o has symbol "memcpy", other 
drivers come with "xf86memcpy". 

Download the XFree86 4.0.1 from ftp.xfree86.org for glibc21, it works 
perfectly. The sis_drv.o doesn't have symbol "memcpy". 

Looking to the xfree86 source, I found the symbol "memcpy" comes from 
init3.o in the sis driver directory, using "nm", I found "memcpy" is the 
last symbol, and is after "gcc_compiled". The init3.c doesn't include any 
call to "memcpy". So the symbol is generated by the compiler.

I also noticed the XFree86 4.0.2 downloaded from xfree86.org has same 
problem as the xserver comes with redhat-7.0.

It seems the problem is caused by some mis-compilation.
Comment 1 Preston Brown 2001-02-26 14:31:29 EST

*** This bug has been marked as a duplicate of 19530 ***
Comment 2 Mike A. Harris 2001-02-26 16:39:49 EST
This is fixed in Rawhide XFree86-4.0.2-11, and will appear shortly.

Note You need to log in before you can comment on or make changes to this bug.