Bug 246732 - Unable to build lightning for ppc
Summary: Unable to build lightning for ppc
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lightning (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F-ExcludeArch-ppc
TreeView+ depends on / blocked
 
Reported: 2007-07-04 14:42 UTC by Jochen Schmitt
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 1.2-9.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 15:22:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jochen Schmitt 2007-07-04 14:42:41 UTC
The bug is blocked, becaused I have some compiling issues on the ppc paltform.

Please see:

http://koji.fedoraproject.org/koji/getfile?taskID=48772&name=build.log

I have contact upstream over the mailing list of the project.

This is a splitt of ob BZ #240230

Comment 1 Jochen Schmitt 2007-07-04 15:46:01 UTC
I have found out the reasons, why the test suite fails on the ppc arch.

On modern(??) ppc64 system there are a execstack protection feature which
prohibit s the execution of dynamic created code from the stack. but this is
what the lightning test suite doing

When I do a 'execstack -s incr' in test test directory, the the 'incr' test is
running as expected.

Comment 2 David Woodhouse 2007-07-05 03:52:04 UTC
That's the same as on modern i386 systems then. The broken package needs fixing,
surely?

Comment 3 Fedora Update System 2007-07-05 19:13:33 UTC
lightning-1.2-9.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2007-07-11 15:22:30 UTC
lightning-1.2-9.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.