Bug 24694 - Anaconda stopped and gave error message, then reboot after installation of packages
Summary: Anaconda stopped and gave error message, then reboot after installation of pa...
Status: CLOSED DUPLICATE of bug 21904
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-23 14:57 UTC by James Myatt
Modified: 2007-04-18 16:30 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-01-24 20:36:34 UTC


Attachments (Terms of Use)

Description James Myatt 2001-01-23 14:57:50 UTC
The following is the error message as dumped to floppy. This message 
appeared almost immediately after the installation of the packages had 
finished.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1664, in 
doInstall
    self.x.write (self.instPath + "/etc/X11")
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 
895, in write
    config4 = self.Version4Config ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 
1173, in Version4Config
    info["enableVariant"] = ""
NameError: info

Local variables in innermost frame:
data: {'screenModes': '\012\011Subsection "Display"\012        
\011Depth       16\012                
Modes       "1280x1024" "1152x864" "1024x768" "800x600" "640x480" \012
\011EndSubsection\012\012\011Subsection "Display"\012        
\011Depth       24\012                
Modes       "1152x864" "1024x768" "800x600" "640x480" \012
\011EndSubsection\012\012\011Subsection "Display"\012        
\011Depth       8\012                
Modes       "1280x1024" "1152x864" "1024x768" "800x600" "640x480" \012
\011EndSubsection\012', 'videoRam': '', 'pex5Mod': '\012
\011Load "pex5"', 'XkbModel': 'pc102', 'monitorVert': '50-
160', 'mouseDevice': 'input/mice', 'cardVendor': 'Matrox 
Mystique', 'cardsOptions': '\011# no known 
options', 'XkbRules': 'xfree86', 'cardBoardName': 'Matrox 
Mystique', 'ia64Mods': '', 'XkbLayout': 'gb', 'nonSparcMods': '\012
\011Load "fbdevhw"', 'defaultDepth': '', 'XkbOptions': '', 'cardID': 'Matro
x Mystique', 'emulate3': 'no', 'enableOptions': '#', 'monitorHoriz': '27-
69', 'enableVariant': '#', 'XkbVariant': 'nodeadkeys', 'mouseProto': 'IMPS/
2', 'files': '\012# The location of the RGB database.  Note, this is the 
name of the\012# file minus the extension (like ".txt" or ".db").  There 
is normally\012# no need to change the default.\012\012    
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are 
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and 
later now use a font server independent of\012# the X server to render 
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012    
FontPath   "unix/:7100"\012'}
self: <xf86config.XF86Config instance at 81f09f0>
maxdepth: 24
res: 640x480
test: 0
mouseProto: IMPS/2
emulate3: no
modes: ['1280x1024', '1152x864', '1024x768', '800x600', '640x480']
depth: 8
screens: 
	Subsection "Display"
        	Depth       16
                
Modes       "1280x1024" "1152x864" "1024x768" "800x600" "640x480" 
	EndSubsection

	Subsection "Display"
        	Depth       24
                Modes       "1152x864" "1024x768" "800x600" "640x480" 
	EndSubsection

	Subsection "Display"
        	Depth       8
                
Modes       "1280x1024" "1152x864" "1024x768" "800x600" "640x480" 
	EndSubsection


ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2001-01-24 20:36:30 UTC

*** This bug has been marked as a duplicate of 21904 ***


Note You need to log in before you can comment on or make changes to this bug.