Bug 24735 - packages not upgraded during 6.2->7.0 upgrade
packages not upgraded during 6.2->7.0 upgrade
Status: CLOSED DUPLICATE of bug 22074
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-01-23 15:11 EST by josip
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-01-23 17:32:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description josip 2001-01-23 15:11:37 EST
High priority: this could hurt thousands of users upgrading 6.2->7.0

The 7.0 installer does not upgrade 6.2 packages whose revision level was
advanced because of a recent bug fix, but removes old 6.2 shared libraries,
so the (updated 6.2) package fails.

An example:  start with 6.2 and apply bug fixes for 6.2.  This installs
gnorpm-0.95.1-5.6x.i386.rpm package.  Then, do 7.0 upgrade which contains
only gnorpm-0.9-27.i386.rpm (which appears to be older than the existing
package).  The package is not replaced, but some of the shared libraries it
needs are.  Starting gnorpm in 7.0 fails because gnorpm-0.95.1-5.6x looks
for an older version of a shared library.

This is a generic problem.  About a dozen other packages (bug fixes/updates
to 6.2) do not get upgraded on 7.0 install (e.g. netscape does not get

Suggestion: take more care in numbering of package revisions and/or ask
user for assistance during the upgrade process when the existing package
appears newer than the one in 7.0.
Comment 1 josip 2001-01-23 17:32:38 EST
I forgot to say that the 7.0 bugfix gnorpm-0.95.1-5.i386.rpm does NOT replace
the 6.2 bugfix gnorpm-0.95.1-5.6x.i386.rpm when using the usual 'rpm -U
gnorpm-0.95.1-5.i386.rpm'.  One has to use the --force flag as well.

Over a dozen other packages fail their 'rpm -Vp [redhat-package-file]' md5 file
tests after upgrade (6.2+bugfixes)->7.0->(7.0+bugfixes), indicating that this
problem is more general than just gnorpm.
Comment 2 Jeff Johnson 2001-03-05 16:28:55 EST

*** This bug has been marked as a duplicate of 22074 ***

Note You need to log in before you can comment on or make changes to this bug.