This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 247483 - Cannot install custom rgb.txt file in RHEL 5
Cannot install custom rgb.txt file in RHEL 5
Status: CLOSED DUPLICATE of bug 245988
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
:
: 247484 247487 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 11:54 EDT by Isaac W.
Modified: 2008-02-24 20:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 14:51:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 12293 None None None Never

  None (edit)
Description Isaac W. 2007-07-09 11:54:06 EDT
Description of problem:
Cannot install a customized rgb.txt file because the /usr/share/X11/rgb.txt 
file is ignored by the X server.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 5 Server running Xorg 7.1.1

How reproducible:


Steps to Reproduce:
1.  Edit the rgb.txt file, changing the "Blue" and "blue" entries to "255 0 0".
2.  Start the X server.
3.  Create an xterm with the following command: "xterm -fg blue".
  
Actual results:
The xterm window appears with blue foreground text.

Expected results:
The xterm window should appear with red foreground text, since the rgb.txt was 
edited to associate the name "blue" with a red color "255 0 0".

Additional info:
No other copies of rgb.txt reside in the system.  Also, there were no errors in 
the /var/log/Xorg.0.log file.  RgbPath is set to "/usr/share/X11/rgb" in the 
xorg.conf file.
Comment 1 Matthias Clasen 2007-07-09 15:36:55 EDT
*** Bug 247484 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Clasen 2007-07-09 15:40:19 EDT
*** Bug 247487 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2007-10-15 23:55:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Adam Jackson 2007-10-31 10:18:36 EDT
Wow, someone actually modifies the rgb database?  How retro.

Devel ack, trivial.
Comment 5 Adam Jackson 2007-11-16 14:51:55 EST

*** This bug has been marked as a duplicate of 245988 ***
Comment 7 Isaac W. 2007-12-06 10:44:36 EST
What is bug 245988?  I can't look at it!  When is this going to be fixed?
Comment 8 Matěj Cepl 2007-12-07 09:30:40 EST
Probably 5.2.
Comment 9 Adam Jackson 2008-02-24 20:54:06 EST
The fix for this bug has been included in the xorg-x11-server package in RHEL 5.2.

Note You need to log in before you can comment on or make changes to this bug.