Bug 247549 - No Data Providers error message on startup
No Data Providers error message on startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qgis (Show other bugs)
6
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
: Reopened
: 349111 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 17:53 EDT by Chris Abrams
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.9.0-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 16:57:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error message on startup (13.24 KB, image/png)
2007-07-09 17:55 EDT, Chris Abrams
no flags Details
Open an OGR Supported Vector Layer dialog box (67.97 KB, image/png)
2007-07-09 17:56 EDT, Chris Abrams
no flags Details
Error message when trying to add a *.shp file as a new vector layer (12.23 KB, image/png)
2007-07-09 17:57 EDT, Chris Abrams
no flags Details

  None (edit)
Description Chris Abrams 2007-07-09 17:53:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.8.0.12) Gecko/20070530 Fedora/1.5.0.12-1.fc6 Firefox/1.5.0.12

Description of problem:
When I launch Quantum GIS, the splash screen appears followed shortly after by an error message informing me that there are no data provider plugins (see attached file startup.png). After clicking the 'OK' button, Quantum GIS continues to load normally. However, if I then try to add a vector layer, the 'Files of type' combo-box in the OGR Vector Layer dialog box has no entries other than 'All Files (*)' (see ogr.png). Moreover, if I try to open a *.shp file, I receive an error informing me that *.shp is not a valid or recognized data source (see unrecognized.png).

Version-Release number of selected component (if applicable):
qgis-0.8.1-10.fc6

How reproducible:
Always


Steps to Reproduce:
1.Open Quantum GIS
2.Click the 'Add a Vector Layer' toolbar button
3.Select a *.shp file

Actual Results:
An error message was displayed (see attached file unrecognized.png).

Expected Results:
The shapefile is added as a new vector layer.

Additional info:
Comment 1 Chris Abrams 2007-07-09 17:55:01 EDT
Created attachment 158809 [details]
Error message on startup
Comment 2 Chris Abrams 2007-07-09 17:56:05 EDT
Created attachment 158811 [details]
Open an OGR Supported Vector Layer dialog box
Comment 3 Chris Abrams 2007-07-09 17:57:01 EDT
Created attachment 158812 [details]
Error message when trying to add a *.shp file as a new vector layer
Comment 4 Douglas E. Warner 2007-07-10 15:35:21 EDT
Please try qgis-0.8.1-11 when it shows up in updates-testing.
Comment 5 Chris Abrams 2007-07-10 15:43:26 EDT
Thanks. I'll look our for it.
Comment 6 Fedora Update System 2007-07-11 11:18:11 EDT
qgis-0.8.1-11.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Douglas E. Warner 2007-07-16 07:45:59 EDT
Does this help at all?
Comment 8 Fedora Update System 2007-07-16 12:59:04 EDT
qgis-0.8.1-11.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Chris Abrams 2007-07-16 14:01:09 EDT
Updated to qgis-0.8.1-11.fc6 but still receiving same error message and still
unable to open a shapefile. Tried removing QGIS package plus all QGIS config
files from my home directory and installing package again, but to no effect.
Comment 10 Chris Abrams 2007-09-28 16:25:26 EDT
Updating to qgis-0.9.0-1.fc6 has fixed this bug on my machine.
Comment 11 Fedora Update System 2007-09-28 17:20:57 EDT
qgis-0.9.0-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2007-10-08 10:59:57 EDT
qgis-0.9.0-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qgis'
Comment 13 Douglas E. Warner 2007-10-23 14:07:55 EDT
*** Bug 349111 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2007-11-05 16:57:20 EST
qgis-0.9.0-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.