Bug 247551 - Plugins path not persisted
Plugins path not persisted
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qgis (Show other bugs)
6
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 18:21 EDT by Chris Abrams
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.0-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 16:57:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
No Plugins found warning message (9.84 KB, image/png)
2007-07-09 18:23 EDT, Chris Abrams
no flags Details

  None (edit)
Description Chris Abrams 2007-07-09 18:21:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.8.0.12) Gecko/20070530 Fedora/1.5.0.12-1.fc6 Firefox/1.5.0.12

Description of problem:
On first starup, Quantum GIS is looking for plugins at the following path:

/usr/bin/../lib/qgis

This path is non-existent on my system. The plugins are actually located in the following directory:

/usr/lib64/qgis

If I change the Plugin Directory to this path in the Plugin Manager dialog box, all the installed plugins are displayed. If I click the 'OK' button and re-open the dialog box, however, I receive a warning message that there are No Plugins (see attached file: no_plugins.png) because the Plugin Manager is again looking in:

/usr/bin/../lib/qgis

for the plugins.

Version-Release number of selected component (if applicable):
qgis-0.8.1-10.fc6

How reproducible:
Always


Steps to Reproduce:
1.Start Quantun GIS
2.Select Plugins->Plugin Manager...
3.Change the Plugin Directory path
4.Click the 'OK' button
5.Select Plugins->Plugin Manager...

Actual Results:
The Plugin Directory changed back to the default.

Expected Results:
The new Plugin Directory should have been persisted.

Additional info:
If after changing the Plugin Directory, all of the installed plugins are selected. new menu entries appear under the Plugins top level menu. While the Plugin Directory is forgotten the next time the Plugin Manager is opened, Quantum GIS remembers which plugins have been selected. However, this information is forgotten if Quantum GIS is re-started.
Comment 1 Chris Abrams 2007-07-09 18:23:15 EDT
Created attachment 158815 [details]
No Plugins found warning message
Comment 2 Juha Tuomala 2007-09-09 08:28:24 EDT
I confirm this.
Comment 3 Douglas E. Warner 2007-09-27 14:37:39 EDT
I've submitted the bug upstream:
https://svn.qgis.org/trac/ticket/771

I believe this is mostly a problem due to bug#247549 which I believe to be 
fixed with the next release (due out soon).
Comment 4 Chris Abrams 2007-09-28 16:22:37 EDT
I confirm this bug was fixed on my machine by updating to the version 0.9.0-1
release in Fedora Extras.
Comment 5 Fedora Update System 2007-10-08 10:59:58 EDT
qgis-0.9.0-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qgis'
Comment 6 Fedora Update System 2007-11-05 16:57:21 EST
qgis-0.9.0-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.