Bug 247706 - python script error in livecd post-install
python script error in livecd post-install
Status: CLOSED DUPLICATE of bug 241754
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-10 16:54 EDT by Daniel Margo
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 10:04:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample wacky kickstart (7.63 KB, application/octet-stream)
2007-07-10 16:54 EDT, Daniel Margo
no flags Details

  None (edit)
Description Daniel Margo 2007-07-10 16:54:28 EDT
Description of problem:
When installing custom livecd spins on kvm, I often encounter the following
python error in post-install:

Traceback (most recent call first):
   File "/usr/lib/anaconda/livecd.py", live 63, in copytree
      except Error, err:
   File "/usr/lib/anaconda/livecd.py", line 223, in _doFilesystemMangling
      "%s/mnt/%s" %(anaconda.rootPath, tocopy))
   File "/usr/lib/anaconda/livecd.py", line 279, in doPostInstall
      self._doFilesystemMangling(anaconda)
   File "/usr/lib/anaconda/backend.py", line 233, in doPostInstall
      anaconda.backend.doPostInstall(anaconda)
   File "/usr/lib/anaconda/dispatch.py", line 203, in moveStep
      rc = stepFunc(self.anaconda)
   File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
      self.moveStep()
   File "/usr/lib/anaconda/text.py", line 605, in run
      anaconda.dispatch.gotoNext()
   File "/usr/sbin/anaconda", line 955, in <module>
      anaconda.intf.run(anaconda)
NameError: global name 'Error' is not defined

The install still completes and runs, although it's unclear to me whether or not
it's the whole of the install I intended.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.66-1

How reproducible:
Consistent within my livecd images, but we are experimenting with some wacky
things in postscript. I've attached one such kickstart.

Steps to Reproduce:
1.livecd-creator --config=<that_kickstart.ks>
2.qemu-img create -f qcow vm-disk.img 4G
3.qemu-kvm -no-acpi -m 384 -cdrom <that_iso.iso> -boot d -hda vm-disk.img -vnc :2
4.vncviewer (or w/e you prefer) into the vm
5.install normally
6.unhappy
  
Actual results:
copytree fails

Expected results:
copytree succeeds, or fails gracefully

Additional info:
At a glance seems to be a pretty simple Python mistake, I just don't have time
to poke at it myself.
Comment 1 Daniel Margo 2007-07-10 16:54:29 EDT
Created attachment 158892 [details]
sample wacky kickstart
Comment 2 Daniel Margo 2007-07-10 17:02:41 EDT
My bad, system won't boot from hard disk, install failed. Upgraded to high priority.
Comment 3 Chris Lumens 2007-07-11 10:04:09 EDT

*** This bug has been marked as a duplicate of 241754 ***

Note You need to log in before you can comment on or make changes to this bug.