Bug 247769 - unresolveable dependency for kdesdk
unresolveable dependency for kdesdk
Status: CLOSED DUPLICATE of bug 250476
Product: Fedora
Classification: Fedora
Component: kdebindings (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 07:37 EDT by Simon Zilliken
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 12:12:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Zilliken 2007-07-11 07:37:37 EDT
Description of problem:

yum update fails becasue of unresolveable dependencies for kdebindings:

[root@localhost ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Running transaction check
---> Package kdebindings.x86_64 0:3.5.7-1.fc7.1 set to be updated
--> Processing Dependency: perl(DCOP) for package: kdesdk
--> Finished Dependency Resolution
Error: Unresolveable requirement perl(DCOP) for kdesdk
Comment 1 Sebastian Vahl 2007-08-14 03:01:50 EDT
Same here on i386. "repoquery -q --whatprovides "perl(DCOP)" shows that this 
packages provides the requirement:
kdebindings-0:3.5.6-1.fc7.i386
kdebindings-dcopperl-0:3.5.7-1.fc7.1.i386

After a manual installation of kdebindings-dcopperl I could update kdesdk. 
After this I've tried to reproduce this and deinstalled kdebindings-dcopperl, 
kdesdk and cleaned the yum cache. But now an installation of kdesdk works fine 
and pulls kdebindings-dcopperl as a requirement.

So this is maybe a yum problem?
Comment 2 Kevin Kofler 2007-08-14 11:58:01 EDT
I'd say it is, if it's possible to satisfy the dependencies, then it's probably 
yum's fault if it can't manage to.
Comment 3 Rex Dieter 2007-08-14 12:12:29 EDT
it's a bug in yum...

*** This bug has been marked as a duplicate of 250476 ***

Note You need to log in before you can comment on or make changes to this bug.