Bug 247893 - RFE: read-only user roles
Summary: RFE: read-only user roles
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management   
(Show other bugs)
Version: Nightly
Hardware: All
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Tazim Kolhar
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
: 199112 251397 568525 576990 707360 (view as bug list)
Depends On:
Blocks: sat-nextgen
TreeView+ depends on / blocked
 
Reported: 2007-07-11 20:51 UTC by Issue Tracker
Modified: 2018-12-09 16:40 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-11 12:28:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 39493 None None None Never

Description Issue Tracker 2007-07-11 20:51:07 UTC
Escalated to Bugzilla from IssueTracker

Comment 1 Issue Tracker 2007-07-11 20:51:13 UTC
Hi

I like to create a user account with only READ rights on the Satellite Server. That means, a user which is able to read all system/channel/entitlement etc. information but is not able to change any of these items. At the moment I only see following Roles

Monitoring Administrator
Activation Key Administrator
Configuration Administrator
Channel Administrator
Organization Administrator
System Group Administrator 

It seems that none of them is satisfactory

Regards Mathias
This event sent from IssueTracker by tdunnon  [SEG - Feature Request]
 issue 117658

Comment 2 Brandon Perkins 2007-07-12 14:26:34 UTC
Read-only functionality is not in the scope of 5.0.1 or 5.1.0.

Comment 4 Máirín Duffy 2007-08-08 18:55:08 UTC
*** Bug 251397 has been marked as a duplicate of this bug. ***

Comment 6 Clifford Perry 2010-10-13 18:00:13 UTC
*** Bug 568525 has been marked as a duplicate of this bug. ***

Comment 7 Miroslav Suchý 2011-01-21 12:21:56 UTC
*** Bug 199112 has been marked as a duplicate of this bug. ***

Comment 8 Miroslav Suchý 2011-01-23 16:39:58 UTC
*** Bug 576990 has been marked as a duplicate of this bug. ***

Comment 11 Clifford Perry 2012-09-24 16:07:15 UTC
*** Bug 707360 has been marked as a duplicate of this bug. ***

Comment 16 Mike McCune 2013-07-18 15:35:45 UTC
Satellite 6 ships with a 'readonly' role that can be assigned to new users.  This allows them to login, look but not change anything in the system.

This protects objects at the API/CLI and WebUI levels to ensure no write access is granted.

Moving to ON_QA so QE can state if they have verified that 'readonly' user works.

Comment 19 Tazim Kolhar 2014-08-13 07:18:58 UTC
VERIFIED

A read only user has access for editing partition-table,user access logs, etc

Comment 21 Bryan Kearney 2014-09-11 12:28:09 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.