Bug 247987 - GDM fails register the session properly at Login.
Summary: GDM fails register the session properly at Login.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-12 15:02 UTC by Chris Jones
Modified: 2008-04-04 06:58 UTC (History)
0 users

Fixed In Version: 2.20.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 06:58:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Jones 2007-07-12 15:02:40 UTC
This bug applies to both FC6 and F7, thus assigning to devel.

+++ This bug was initially created as a clone of Bug #244426 +++

Description of problem:
GDM fails register the session properly at Login. This means X users don't
appear to the standard tools (w, who, etc..). This means the admin think its
safe to shutdown or reboot machines when its really not. This *REALY* annoys users!

How reproducible:
Login under X and then, from a console, check if you logged in useing w or who.
Note the X session is not listed.

Additional info:
The supplied patch works. Please apply!

-- Additional comment from klaus@ethgen.de on 2007-06-15 12:00 EST --
Created an attachment (id=157128)
patch for /etc/gdm/PreSession/Default

Comment 1 Ray Strode [halfline] 2007-07-12 17:07:19 UTC
Does it work with the version of gdm that landed in rawhide last night?

Comment 2 Ray Strode [halfline] 2007-08-14 15:52:05 UTC
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)

Comment 3 Sitsofe Wheeler 2007-08-17 05:20:26 UTC
Can this be reopened and assigned to F7? 

Comment 4 Ray Strode [halfline] 2007-08-17 14:56:55 UTC
Sitsofe Wheeler, I can do an F7 update if you'd like.

Comment 5 Sitsofe Wheeler 2007-08-21 21:04:46 UTC
Ray:
That would be excellent - we'll give it whirl if you can do so...


Note You need to log in before you can comment on or make changes to this bug.