Bug 248061 - vsftpd creates files with random permissions
vsftpd creates files with random permissions
Status: CLOSED DUPLICATE of bug 244686
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vsftpd (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Maros Barabas
Depends On:
  Show dependency treegraph
Reported: 2007-07-12 17:35 EDT by Bill Smargiassi
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-13 03:14:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Smargiassi 2007-07-12 17:35:40 EDT
Description of problem:

Since 1.2.1-3E-12 was installed as the latest errata, permissions created on files uploaded by local 
users appear to be assigned randomly! In other words, from the standard Linux ftp command line client 
as provided by Red Hat EL 4, 2 different sessions from the same client can result in different 
permissions. Usually similar to --xr--rw- or ---------. All settings of file_open_mode and 
local_umask are ignored (we are aware of the /etc/vsftpd.conf vs. /etc/vsftpd/vsftpd.conf confusion on 
RHEL and have one soft-linked to the other, but this problem occurred before the soft-linking as well). 
Users are not able to access files left for them. Most of our users do not understand Unix perms, so 
they can't fix it themselves. Using the OS X client Cyberduck with it's default of matching local 
permissions, all uploads appear to be readable with sane perms. All default OS command line FTP 
programs we tried exhibit this random permissions problem, but perms can be fixed with 'site chmod'.

See http://www.redhat.com/archives/taroon-list/2007-June/msg00032.html for corroboration. 
Downgrading to 1.2.1-3E-6 as suggested fixed our problem as well.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Log in to vsftpd as a local user.
2. Upload a file
3. Check file permissions.
Actual results:

Permissions on the newly created file are randomly assigned, nearly always leaving the owner without 
read and write.

Expected results:

Permissions should obey file_open_mode and local_umask settings.

Additional info:

We are using vsftpd from xinetd and chrooted local accounts.
Comment 1 Maros Barabas 2007-07-13 03:14:17 EDT

*** This bug has been marked as a duplicate of 244686 ***

Note You need to log in before you can comment on or make changes to this bug.