Bug 248094 - No alpha support for redhat-lsb
No alpha support for redhat-lsb
Status: CLOSED DUPLICATE of bug 306471
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Lawrence Lim
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-07-13 02:56 EDT by Oliver Falk
Modified: 2014-03-25 20:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-05 05:59:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-07-13 02:56:42 EDT
Hi Jesse!

Could you please have a look into this diff and fix it in cvs, if it's OK.

I'm not 100% sure if the requires is OK. Eg. I only have libc.so.6.1 - maybe
only a built problem of my glibc... I have to clarify that...

Index: redhat-lsb.spec
RCS file: /cvs/pkgs/devel/redhat-lsb/redhat-lsb.spec,v
retrieving revision 1.28
diff -u -p -r1.28 redhat-lsb.spec
--- redhat-lsb.spec     2 May 2007 05:10:15 -0000       1.28
+++ redhat-lsb.spec     13 Jul 2007 06:53:58 -0000
@@ -36,6 +36,11 @@
 %define lsbldso ld-lsb-x86-64.so

+%ifarch alpha
+%define ldso ld-linux.so.2
+%define lsbldso ld-lsb.so
 %ifarch ia64 ppc64 s390x x86_64
 %define qual ()(64bit)
@@ -81,12 +86,15 @@ Provides: lsb = %{version}
 %ifarch x86_64
 %define archname amd64
+%ifarch alpha
+%define archname alpha
 Provides: lsb-core-%{archname} = %{version}
 Provides: lsb-graphics-%{archname} = %{version}
 Provides: lsb-core-noarch = %{version}
 Provides: lsb-graphics-noarch = %{version}

-ExclusiveArch: i386 ia64 x86_64 ppc ppc64 s390 s390x
+ExclusiveArch: i386 ia64 x86_64 ppc ppc64 s390 s390x alpha

 %ifarch %{ix86}
 # archLSB IA32 Base Libraries
@@ -186,6 +194,20 @@ Requires: libc.so.6()(64bit)
 Requires: libstdc++.so.6()(64bit)

+%ifarch alpha
+# archLSB Alpha Base Libraries
+Requires: libz.so.1
+Requires: libutil.so.1
+Requires: libpthread.so.0
+Requires: libncurses.so.5
+Requires: libm.so.6
+Requires: libgcc_s.so.1
+Requires: libdl.so.2
+Requires: libcrypt.so.1
+Requires: libc.so.6
+Requires: libstdc++.so.6
 # gLSB Base/Utility/Stdc++/Graphics Libraries
 Requires: libz.so.1%{qual}
 Requires: libutil.so.1%{qual}
Comment 1 Oliver Falk 2007-11-05 05:59:05 EST

*** This bug has been marked as a duplicate of 306471 ***

Note You need to log in before you can comment on or make changes to this bug.