Bug 248247 - Install on >15 partitions fails after checking deps and formatting
Install on >15 partitions fails after checking deps and formatting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-14 01:42 EDT by 157bug
Modified: 2008-01-30 08:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 15:34:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dump of report to file against anaconda (91.17 KB, text/plain)
2007-07-14 01:46 EDT, 157bug
no flags Details
anacdump.txt (83.92 KB, text/plain)
2007-07-23 23:08 EDT, Felix Miata
no flags Details

  None (edit)
Description 157bug 2007-07-14 01:42:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20061201 Firefox/2.0.0.4 (Ubuntu-feisty)

Description of problem:
I receive notices that Fedora 7 cannot work with partitions >15 with "reboot"-"continue" notices. Choosing continue the installation fails after checking deps and formatting with a notice to file a bug report against anaconda.
It is not clear if simply having >15 partitions causes this or if there is another issue.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Attempt install
2.
3.

Actual Results:
Install fails with notice to file bug report against anaconda

Expected Results:
Sucessful installation to partition <15

Additional info:
Comment 1 157bug 2007-07-14 01:46:39 EDT
Created attachment 159266 [details]
Dump of report to file against anaconda
Comment 2 157bug 2007-07-15 15:01:41 EDT
Additional followup to make my report clearer.
The hard drive has more than 15 partitions and I was attempting to install
Fedora 7 to one root partition on the drive. I tried at partition 15 and then 10.
I tried both the install DVD and LiveCD.
I tried installing to a pre-formatted partition and not asking for the install
program to format.
All attempts fail.
Comment 3 Felix Miata 2007-07-23 17:19:28 EDT
I see this too, although I'm not trying to install to <15. My Fedora 5 is on
hda21, but instead of wiping that out I want to install on hda29 in an a PATA
only system. I've been asking on the mailing list without success and searching
release notes, installation guide and bugzilla without success in finding
anything useful regarding working around or past libata's SCSI partition count
limitation in Fedora like SUSE has in brokenmodules=ata_piix to prevent use of
libata in https://bugzilla.novell.com/show_bug.cgi?id=214992 and is working to
improve on https://bugzilla.novell.com/show_bug.cgi?id=218122.
Comment 4 Felix Miata 2007-07-23 23:08:49 EDT
Created attachment 159828 [details]
anacdump.txt
Comment 5 Felix Miata 2007-07-29 08:02:50 EDT
I tried to install F7 onto #11 on another system with 19 PATA partitions, but
anaconda aborted with no such device /dev/sda15, which is labeled as
S12A-15home. Install succeeded after I removed partition table entries for
partitions >14. System seems to work fine after restoring all original partition
table entries, though those >15 have no device entries and are thus inaccessible.
Comment 6 157bug 2007-07-29 19:14:01 EDT
It looked to me like a failure to rewrite the partition table is what caused my
install failures.
Your solution would seem to involve using "dd" to backup the partition table,
delete partitions in the installer, then restore the correct partition table? Yikes.
Comment 7 Felix Miata 2007-07-29 20:55:07 EDT
I use a cross-platform partitioner http://www.dfsee.com/dfsee/ that makes
deleting and recreating partition table entries without altering any partition
content a relatively easy and painless process. But, no one should have to go
through that just to get a modern Linux to install.

Because of my pre-partitioning, there's no reason for the installer to do
anything with partition tables except read them. I do my best with any Linux
installer to answer its questions such that it knows not to change my partition
tables, but right now Anaconda makes it hard to tell how to give it safe
answers. e.g., it currently provides no *apparent* option to install grub
anywhere except on the MBR, so I'm forced to tell it no boot loader, start it
from another grub or chroot, then install it where it should have in the first
place, on either / or /boot.

Due to apparent lack of docs on >15 partition obstacles stemming from
converstion from traditional ide drivers to libata, I've filed a documentation
bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249399
Comment 8 157bug 2007-07-29 22:40:14 EDT
(In reply to comment #7)
> But, no one should have to go
> through that just to get a modern Linux to install.

I agree, but I recall seeing comments from both Linus and Fedora that they do
not intend to support anything beyond the 15 partition limit in the future.

I prefer to use cfdisk to partition and GRUB to boot but I also have Acronis
Disk Director available.

Since this is not a problem with any other distribution I use yet (latest
Ubuntu, Debian, and Slack, besides other older), I delay any installation of
Fedora until there is a solution.

I am not going to hide partitions and change bootloaders unless it becomes a
general issue.

I find it odd that when my next hard drive could be closing in on 1TB I will be
restricted to fewer partitions than I currently use.



Comment 9 Felix Miata 2007-07-30 00:17:30 EDT
Some people wonder why people still use OS/2, but OS/2 has no per device
partition count limit. AFAIK, neither does windoz. OTOH, I have seen it written
that the partition limit in Linux should be solved in userspace, not the kernel,
which is where I think SUSE is working, and maybe Mandriva.
Comment 10 David Cantrell 2007-08-16 15:34:31 EDT
This is not a problem with anaconda, but a limitation of the Linux kernel.  The
Linux kernel cannot support more than 15 partitions per device.  It's a
limitation of the SCSI subsystem in the 2.6 kernel and it's well known.  All we
can do is work within those bounds, hence the warning messages.

Continue is given as an option because you _can_ install on a disk with more
than 15 partitions, so long as Linux is installed entirely within the first 15
partitions.
Comment 11 157bug 2007-08-16 20:53:19 EDT
>Continue is given as an option because you _can_ install on a disk with more
than 15 partitions, so long as Linux is installed entirely within the first 15
partitions.<

Sorry if I was not clear. I attempted to install to a root partition at
partition 15 and then again at 10 (with swap at partition 7). The install fails
only with a message to file a report against Anaconda.
Comment 12 Felix Miata 2007-08-16 21:21:59 EDT
(In reply to comment #11)
> >Continue is given as an option because you _can_ install on a disk with more
> than 15 partitions, so long as Linux is installed entirely within the first 15
> partitions.<

> Sorry if I was not clear. I attempted to install to a root partition at
> partition 15 and then again at 10 (with swap at partition 7). The install fails
> only with a message to file a report against Anaconda.

IOW, this is a current bug in that attempts to install to below partition 16
fail when more than 15 partitions exist. No apparent documentation exists to
support comment 10. Someone with power to do so should reopen this until such
time as installing below 16 when more than 15 exist is demonstrably possible.
See bug 249399
Comment 13 David Balažic 2008-01-30 08:03:31 EST
> No apparent documentation exists to support comment 10.

Yes it does devices.txt in linux-2.6.23 (and older) :
http://lxr.linux.no/linux/Documentation/devices.txt

#  8 block SCSI disk devices (0-15)
...
# Partitions are handled in the same way as for IDE
# disks (see major number 3) except that the limit on
# partitions is 15.

Of course, a 15 partitions limit in the 21st century is ridiculous.

Note You need to log in before you can comment on or make changes to this bug.