Bug 248257 - dcdbas doesn't load
dcdbas doesn't load
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 250440 (view as bug list)
Depends On:
Blocks: 237767
  Show dependency treegraph
 
Reported: 2007-07-14 09:34 EDT by darrell pfeifer
Modified: 2007-12-06 18:36 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.6.23.1-63.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 18:36:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dcdbas-autoload.patch (530 bytes, patch)
2007-10-28 23:07 EDT, Matt Domsch
no flags Details | Diff
dcdbas-autoload.patch (437 bytes, patch)
2007-10-29 17:11 EDT, Matt Domsch
no flags Details | Diff

  None (edit)
Description darrell pfeifer 2007-07-14 09:34:48 EDT
Description of problem:

The dcdbas module isn't being loaded on an Inspiron 9300.

dcdbas.ko is found in

/lib/modules/`uname -r`/kernel/drivers/firmware/dcdbas.ko

but modprobe doesn't search the firmware directory.

The module can be loaded using insmod and a full pathname.

Version-Release number of selected component (if applicable):

2.6.22-8.fc8

(The newer '23' kernels do the same thing, but the current one is dead and the
previous one was deleted due to a problem with the installonlyn plugin)


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Bug 246106 is filed against NetworkManager to reduce the amount of chatter to
/var/log/messages
Comment 1 darrell pfeifer 2007-07-15 08:15:11 EDT
The issue of modprobe not finding the firmware directory has been resolved with
udev-113-4.fc8

dcdbas still isn't loaded at system startup but modprobe can be used to load it
afterwards.
Comment 2 Dave Jones 2007-08-06 14:39:20 EDT
auto-loading support needs addition of DMI strings to its module table.

The documentation suggests that this is only really useful on Poweredge systems,
does it do anything useful on your Inspiron ?
Comment 3 darrell pfeifer 2007-08-06 14:53:46 EDT
I also doubt that it does anything useful. It looks like NetworkManager is
taking a guess at problem resolution when it can't find the /sys file it expects

Aug  6 11:41:35 localhost NetworkManager: <info>  Error getting killswitch
power: org.freedesktop.Hal.Device.UnknownError - An Error occurred. The Error
message is:  #012 Could not open file /sys/devices/platform/dcdbas/smi_data.
Check that dcdbas driver is properly loaded.

modprobing dcdbas results in NetworkManager saying

Aug  6 11:49:41 localhost kernel: dcdbas dcdbas: Dell Systems Management Base
Driver (version 5.6.0-3.2)
Aug  6 11:49:47 localhost NetworkManager: <info>  Error getting killswitch
power: org.freedesktop.Hal.Device.KillSwitch.NotSupported - dellWirelessCtl
returned 4

I was hoping that bug 246106 would result in the NetworkManager code being
changed so that it stops complaining bitterly every 5 seconds.

This bug is here for the DMI and /sys problem (regardless of dcdbas not being
the correct solution)
Comment 4 Dave Jones 2007-08-06 15:18:41 EDT
*** Bug 250440 has been marked as a duplicate of this bug. ***
Comment 5 Espen Stefansen 2007-08-30 10:47:48 EDT
This still happens on my Dell D630 as of rawhide 20070830.

But after i load it, i only get this message in messages:
Aug 30 16:28:07 itse68482 kernel: dcdbas dcdbas: Dell Systems Management Base
Driver (version 5.6.0-3.2)

No error from NetworkManager as in Comment #3
Comment 6 Espen Stefansen 2007-10-27 19:39:59 EDT
NetworkManager still complains about this on boot. Dell D630 with iwl4965.

NetworkManager: <WARN>  killswitch_getpower_reply(): Error getting killswitch
power: An Error occurred. The Error message is:  #012 Could not open file
/sys/devices/platform/dcdbas/smi_data. Check that dcdbas driver is properly loaded..

kernel-2.6.23.1-37.fc8
NetworkManager-0.7.0-0.5.svn3030.fc8
Comment 7 Rui Matos 2007-10-28 20:02:18 EDT
(In reply to comment #2)
> auto-loading support needs addition of DMI strings to its module table.

So, it can be easily solved?

> The documentation suggests that this is only really useful on Poweredge systems,
> does it do anything useful on your Inspiron ?

Well, if we want hardware to just work then yea, it needs to be loaded
automatically. For instance, on a Latitude D630 if this module isn't loaded
before HAL starts, then gnome-power-manager won't be able do dim the laptop's
backlight.

What is needed exactly for this to be solved? Dell has some quite responsive
people on their mailing lists that I'm sure would be of help here. Hmm,
apparently one them is already on this bug's CC.
Comment 8 Matt Domsch 2007-10-28 21:52:33 EDT
Dell knows about this, but the dcdbas author has been tied up with other work. 
I expect it will be a simple addition to the driver, a MODULE_ALIAS() line or
two to match DMI strings, but looking at the patch that added that feature, I
couldn't figure out what that line should be exactly.

Yes, it is valuable aside from just PowerEdge.  Wireless and backlight controls
on  notebooks, blinking lights on XPS desktops, and the like all go through this
driver.
Comment 9 Matt Domsch 2007-10-28 23:07:45 EDT
Created attachment 241071 [details]
dcdbas-autoload.patch

I think this will work.  It works for me on my Latitude D610.
Comment 10 Matt Domsch 2007-10-29 17:11:37 EDT
Created attachment 242401 [details]
dcdbas-autoload.patch

Updated patch based on feedback from Kay Sievers.
Comment 11 Matt Domsch 2007-10-29 17:25:36 EDT
The above patch was sent to lkml for inclusion in mainline.
Comment 12 Rui Matos 2007-10-29 17:47:43 EDT
Thanks a bunch Matt!

Now, can this still make it into Fedora 8? Pretty please! :-)
Comment 13 Matt Domsch 2007-10-29 17:59:46 EDT
Rui, it's quite late - it won't make it into 2.6.24 or Fedora 8, but can be
added in an F8 update kernel soon after release, and into 2.6.25.  Please remind
us after F8 is released.

Thanks,
Matt
Comment 14 Rui Matos 2007-11-14 18:58:55 EST
Can this now go into an updated fedora 8 kernel?
Comment 15 Chuck Ebbert 2007-11-15 15:09:25 EST
In F8 and rawhide CVS.
Comment 16 Espen Stefansen 2007-11-16 20:31:53 EST
I tried kernel-2.6.23.1-58.fc8 from koji and now it loads dcdbas on boot. :)

Note You need to log in before you can comment on or make changes to this bug.