Bug 250440 - hal needs to load dcdbas kernel module on Dell systems
hal needs to load dcdbas kernel module on Dell systems
Status: CLOSED DUPLICATE of bug 248257
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-01 12:29 EDT by Matt Domsch
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 15:18:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dell.modules (154 bytes, application/octet-stream)
2007-08-01 12:29 EDT, Matt Domsch
no flags Details

  None (edit)
Description Matt Domsch 2007-08-01 12:29:00 EDT
Description of problem:
hal doesn't load the dcdbas kernel module automatically.  This causes continuous
syslog error messages:

NetworkManager: <info> Error getting killswitch power:
org.freedesktop.Hal.Device.UnknownError - AN error occurred.  The error message
is: #012 Could not open file /sys/devices/platform/dcdbas/smi_data.  Check that
dcdbas driver is properly loaded.

Version-Release number of selected component (if applicable):
hal-0.5.9-8.fc7

How reproducible:
always on Dell laptops

Steps to Reproduce:
1. start networkmanager
2.
3.
  
Actual results:
errors seen in syslog

Expected results:
no errors

Additional info:
Attachment dell.modules can be dropped into /etc/sysconfig/modules/ to be
automatically loaded by initscripts.  This stops such error messages.
Comment 1 Matt Domsch 2007-08-01 12:29:01 EDT
Created attachment 160428 [details]
dell.modules
Comment 2 David Zeuthen 2007-08-01 14:55:37 EDT
Actually I would say that libsmbios should insmod dcdbas itself and/or drop that
file into /etc/sysconfig/modules. Much like e.g. mount(1) loads file-system
drivers when needed. Or how losetup loads loop.ko when needed.

Anyway this is all moot, since DMI modalias support is landing / has landed in
recent Linux kernels. I believe dcdbas should just export modalias to make this
load automatically as part of the boot process.

Hence, reassigning to the kernel to make sure we do that.

Comment 3 Dave Jones 2007-08-06 15:18:38 EDT

*** This bug has been marked as a duplicate of 248257 ***

Note You need to log in before you can comment on or make changes to this bug.