Bug 248290 - 0.9.4 is out
0.9.4 is out
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mercurial (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 253544 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-15 05:31 EDT by Florian La Roche
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 10:34:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-07-15 05:31:54 EDT
Description of problem:

Mercurial has released version 0.9.4. Ok to update the Fedora-devel
version of it?

regards,

Florian La Roche


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Till Maas 2007-08-11 17:04:17 EDT
Oh, and I hoped to see mercurial 0.9.4 even in F-7. I just found out that
mercurial 0.9.3 does not support symlinks, but 0.9.4 does, which is for me a big
improvement.
Comment 2 Jeremy Katz 2007-08-21 17:15:53 EDT
*** Bug 253544 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan S. Shapiro 2007-08-24 17:06:23 EDT
Jeremy:

This "resolution" is really not OK. Let me try to explain why:

Many Fedora users are sitting on hosted services or other production
environments. As an example, I have a machine at SoftLayer. They won't be
deploying F7 until early October, so one can assume that their F8 deploy will
not happen until something like March/April 2008.  On the one hand, there are
good reasons for that. On the other, mercurial users in that position are placed
in a difficult situation by the NEXTRELEASE resolution. Speaking for myself, it
isn't even good enough to get this for F7. I need it for FC6 because of the
production deployment issue.

IMO, the decision to take Fedora to a 6 month release cycle was a big mistake,
because it promotes exactly the sort of decision that you just made, and it
leaves production users in the cold. Don't get me wrong -- I understand that you
are under pressure here. My point is that the source of the pressure is an
impossible release turn time.

If you don't have time to do this, are you open to letting someone else deal
with it?
Comment 4 Jonathan S. Shapiro 2007-08-24 17:07:39 EDT
Sorry. Should have added: I might be willing to volunteer to assist.

Note You need to log in before you can comment on or make changes to this bug.