Bug 248329 - snmpconf generates snmpd.conf file with wrong SELINUX context
Summary: snmpconf generates snmpd.conf file with wrong SELINUX context
Status: CLOSED DUPLICATE of bug 247462
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Safranek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 192447
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-16 07:15 UTC by Jan Safranek
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 07:17:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Safranek 2007-07-16 07:15:14 UTC
+++ This bug was initially created as a clone of Bug #192447 +++

Description of problem:

used snmpconf to generate an snmpd.conf file.  file was created without proper
SELINUX user/context as compared to the stock snmpd.conf file.

Version-Release number of selected component (if applicable):

net-snmp-libs-5.1.2-11.EL4.6
net-snmp-5.1.2-11.EL4.6
net-snmp-utils-5.1.2-11.EL4.6


How reproducible:

Always

Steps to Reproduce:
1. cd /etc/snmp
2. mv snmpd.conf snmpd.conf.orig
3. snmpdconf
  
Actual results:

# ls -lZ
-rw-r--r--  root     root     root:object_r:etc_t              snmpd.conf
-rw-r--r--  root     root     system_u:object_r:snmpd_etc_t    snmpd.conf.orig


Expected results:

-rw-r--r--  root     root     system_u:object_r:snmpd_etc_t    snmpd.conf
-rw-r--r--  root     root     system_u:object_r:snmpd_etc_t    snmpd.conf.orig

Additional info:

had to manually - chcon -u system_u -t snmpd_etc_t snmpd.conf

Comment 1 Jan Safranek 2007-07-16 07:17:03 UTC
accidentaly posted this twice

*** This bug has been marked as a duplicate of 247462 ***


Note You need to log in before you can comment on or make changes to this bug.