Bug 248556 - 'Lost' USB events? Temporarily fixed by removing/reinserting device
'Lost' USB events? Temporarily fixed by removing/reinserting device
Status: CLOSED DUPLICATE of bug 248783
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-17 09:54 EDT by Tom London
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 09:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file showing problem with USB mouse removal (38.59 KB, text/plain)
2007-07-23 14:56 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2007-07-17 09:54:44 EDT
Description of problem:
2.6.23-0.29.rc0.git6.fc8PAE seems to 'lose' USB events (cursor, keyboard).

I can temporarily work around by pulling out and reinserting the device.

I sometimes get the following:

Jul 16 17:07:08 localhost kernel: usb 5-6.1: USB disconnect, address 5
Jul 16 17:07:08 localhost kernel: *** SLUB sysfs_dir_cache: Padding check failed
in slab @0xc1678d3c [Not tainted]
Jul 16 17:07:08 localhost kernel:  [<c04061a8>] show_trace_log_lvl+0x1a/0x2f
Jul 16 17:07:08 localhost kernel:  [<c0406c18>] show_trace+0x12/0x14
Jul 16 17:07:08 localhost kernel:  [<c0406c71>] dump_stack+0x16/0x18
Jul 16 17:07:08 localhost kernel:  [<c0480758>] slab_err+0x51/0x57
Jul 16 17:07:08 localhost kernel:  [<c04807c2>] slab_pad_check+0x64/0x90
Jul 16 17:07:08 localhost kernel:  [<c0480928>] check_slab+0x13a/0x147
Jul 16 17:07:08 localhost kernel:  [<c04813be>] __slab_free+0xbd/0x278
Jul 16 17:07:08 localhost kernel:  [<c0481d32>] kmem_cache_free+0x77/0x97
Jul 16 17:07:08 localhost kernel:  [<c04c00a1>] release_sysfs_dirent+0x6e/0x83
Jul 16 17:07:08 localhost kernel:  [<c04c02c4>] sysfs_addrm_finish+0x1dd/0x1f6
Jul 16 17:07:08 localhost kernel:  [<c04befde>] sysfs_hash_and_remove+0x52/0x7f
Jul 16 17:07:08 localhost kernel:  [<c04c1107>] sysfs_remove_link+0xb/0xd
Jul 16 17:07:08 localhost kernel:  [<c056c570>] bus_remove_device+0x22/0x82
Jul 16 17:07:08 localhost kernel:  [<c056ad21>] device_del+0x212/0x288
Jul 16 17:07:08 localhost kernel:  [<c0582b22>] usb_disable_device+0x5f/0xbc
Jul 16 17:07:08 localhost kernel:  [<c057f0f6>] usb_disconnect+0x9a/0x134
Jul 16 17:07:08 localhost kernel:  [<c057f7fe>] hub_thread+0x373/0xa49
Jul 16 17:07:08 localhost kernel:  [<c043bb0f>] kthread+0x3b/0x64
Jul 16 17:07:08 localhost kernel:  [<c0405c8b>] kernel_thread_helper+0x7/0x10
Jul 16 17:07:08 localhost kernel:  =======================
Jul 16 17:07:08 localhost kernel: @@@ SLUB sysfs_dir_cache: Restoring slab
padding (0x5a) from 0xdfdcbfc0-0xdfdcbfff
Jul 16 17:07:11 localhost kernel: usb 5-6.1: new low speed USB device using
ehci_hcd and address 9
Jul 16 17:07:12 localhost kernel: usb 5-6.1: configuration #1 chosen from 1 choice
Jul 16 17:07:12 localhost kernel: input: Microsoft Basic Optical Mouse as
/class/input/input8
Jul 16 17:07:12 localhost kernel: input: USB HID v1.10 Mouse [Microsoft Basic
Optical Mouse] on usb-0000:00:1d.7-6.1
Jul 16 17:09:13 localhost kernel: usb 5-6.1: USB disconnect, address 9
Jul 16 17:09:16 localhost kernel: usb 5-6.1: new low speed USB device using
ehci_hcd and address 10
Jul 16 17:09:16 localhost kernel: usb 5-6.1: configuration #1 chosen from 1 choice
Jul 16 17:09:16 localhost kernel: input: Microsoft Basic Optical Mouse as
/class/input/input9
Jul 16 17:09:16 localhost kernel: input: USB HID v1.10 Mouse [Microsoft Basic
Optical Mouse] on usb-0000:00:1d.7-6.1
Jul 16 17:09:50 localhost ntpd[2603]: synchronized to 62.44.101.22, stratum 2
Jul 16 17:09:50 localhost ntpd[2603]: kernel time sync status change 0001
[root@localhost ~]# 


Version-Release number of selected component (if applicable):
2.6.23-0.29.rc0.git6.fc8PAE

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2007-07-18 21:01:11 EDT
Have similar (worse?) issues with 2.6.23-0.30.rc0.git6.fc8PAE:

USB keyboard missed the first character typed, and USB mouse is 'lost'.

After about 60 seconds of 'use', I get a hard system freeze: have to power cycle
to recover.  Nothing in /var/log/messages......

I'm running on Thinkpad X60.  
Comment 2 Tom London 2007-07-19 09:48:02 EDT

*** This bug has been marked as a duplicate of 248783 ***
Comment 3 Pete Zaitcev 2007-07-21 17:15:36 EDT
I'm not convinced it's the same issue that Nicolas has. You should've not
merged them. It's trivial to dup bugs, but divorcing them is much harder.

If the kernel crashes, it's time to get netconsole or serial console set up,
unless you're able to save dmesg and sync in these 60 seconds.
Comment 4 Tom London 2007-07-21 17:47:58 EDT
Sorry for prematurely merging.  Would you prefer that I open another with a copy
of this info?

Here is where I am at:
Each kernel AFTER kernel-PAE-2.6.23-0.15.rc0.git1.fc8, up to and including
kernel-PAE-2.6.23-0.41.rc0.git14.fc8 exhibits the same behavior: at gnome
greeter screen, USB mouse is frozen and the first character typed (on USB
keyboard) is 'lost' (so typing 'abc' for login yields 'bc'). After the first
lost character, I can gnome login, but I have to pull out and reinsert the usb
mouse to regain the cursor.

ALT-F1 works, and I can enter text on 'console'.

Some time later, typically after I've brought up firefox (or some such), system
freezes.  Can take up to 5-10 minutes.

Looks like kernel-2.6.23-0.43.rc0.git16.fc8 just finished on koji. I will
download/install and see if anything has changed......
Comment 5 Tom London 2007-07-21 18:33:57 EDT
No joy with kernel-PAE-2.6.23-0.43.rc0.git16.fc8: same behavior as above:
kernels after 0.15.rc0.git1.fc8 drop USB keyboard characters, USB mouse gets
lost, system freezes.

This time I tried running 'watch -n 2 "dmesg | tail"' in a terminal window, but
got no data on the crash. [I was running rhythmbox with Internet radio at the
time.... got hard quarter second audio 'loop'.]

Sigh.... I'll look into setting up net-/serial-console.

BTW, I the last 'SLUB padding check failed' message I got was with
2.6.23-0.29.rc0.git6.fc8PAE.
Comment 6 Tom London 2007-07-22 00:41:12 EDT
I'm having no luck setting up 'netconsole'.

I've setup /etc/sysconfig/netconsole and enabled the netconsole service.
I've setup a FC6 machine with 'nc -l -u 7654' (7654 is the port number I 
config'ed in /etc/sysconfig/netconsole), but I get no packets.
I can 'nc -u 192.168.1.102 7654' from the Rawhide machine and the packets get there.

I completely disabled the firewall on the FC6 machine, but no luck.

Are there any issues with netconsole and e1000 driver?

Am I doing something dumb?
Comment 7 Tom London 2007-07-23 14:56:27 EDT
Created attachment 159803 [details]
log file showing  problem with USB mouse removal

OK, I got a crash with log with .45 (from koji).

Has several BUG's, lots of Slab INFOs, etc.

I believe I can reproduce this.

Note You need to log in before you can comment on or make changes to this bug.