This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 248783 - USB input death then system freeze
USB input death then system freeze
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 248556 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-07-18 15:10 EDT by Nicolas Mailhot
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23-0.174.rc6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 16:18:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 8535 None None None Never

  None (edit)
Description Nicolas Mailhot 2007-07-18 15:10:17 EDT
All the info is in the upstream bug
Comment 1 Tom London 2007-07-19 09:48:08 EDT
*** Bug 248556 has been marked as a duplicate of this bug. ***
Comment 2 Tom London 2007-07-21 14:07:13 EDT
I continue to have USB loss and eventual system freeze with all kernels after
kernel-PAE-2.6.23-0.15.rc0.git1.fc8, including today's
kernel-PAE-2.6.23-0.41.rc0.git14.fc8.  (0.15.rc0.git1 is the last stable kernel
for me).

I do not see any pattern in /var/log messages.

My system is a Thinkpad X60.

What info/debugging can I provide?
Comment 3 Nicolas Mailhot 2007-07-21 18:49:09 EDT
upstream devs want usbmon traces. look at the bugzilla.kernel.org bug
Comment 4 Tom London 2007-07-22 00:37:09 EDT
OK.  Read instructions....

Will setup and collect....
Comment 5 Tom London 2007-08-08 10:01:55 EDT
I've been applying the patch filed upstream for the past several kernel
packages. 'Fixes for me'.

For me, the issue seems to be 'slow USB' devices (e.g., mouse/keyboard) on EHCI
ports.

The patch refers to nVidia controllers, although I believe I have 'slow devices'
connected to Intel ICH7 EHCI through the Thinkpad X60 dock.

Both upstream and Fedora patches attached here:
http://bugzilla.kernel.org/show_bug.cgi?id=8535

I'm not sure what more to do to push this upstream, or if this is already
working its way through the process.
Comment 6 Tom London 2007-08-23 12:43:04 EDT
This appears to 'work for me' with kernel-2.6.23-0.129.rc3.git4.fc8.

That likely, or am I just seeing random stuff....
Comment 7 Nicolas Mailhot 2007-08-23 13:03:36 EDT
I don't think you're seeing stuff, that's the first post 2.6.22 rawhide kernel
that seems to work here (but this bug didn't always trigger fast on my system,
so it's a bit early to declare the bug closed)
Comment 8 Pete Zaitcev 2007-08-23 14:01:58 EDT
The matter is being worked upon by Stuart. Linus backed out his original
fix for EHCI losing data when CPU frequency changed, so this is probably
what you two are seeing.

Start around here and navigate down thread:
http://lkml.org/lkml/2007/8/20/369
Comment 9 Will Woods 2007-10-03 15:58:58 EDT
I hit something similar to this recently, on a 2.6.23-rc7 kernel. The upstream
bug is months old and still in NEW. Is this thought to be fixed upstream, or are
we still waiting for a patch to land?
Comment 10 Will Woods 2007-10-03 16:03:37 EDT
Err, of course, there is another possible explanation: I am seeing something
entirely different and should file that bug elsewhere. I checked the logs and
the telltale "drivers/hid/usbhid/hid-core.c: input irq status -75 received"
message is not there. So probably I'm seeing something else.

Still, I'd like to know if this is supposed to be CLOSED UPSTREAM or if it's
still an open issue.
Comment 11 Nicolas Mailhot 2007-10-03 16:10:56 EDT
IMHO it's closed upstream or at least I'm not hitting it anymore on my system
(both on mm and fedora kernels)
Comment 12 Pete Zaitcev 2007-10-03 16:18:16 EDT
Will, this bug tracks what was happening to Nicolas, e.g. the fallout from
Stuart's attempts to fix EHCI coughing up a lung upon a CPU frequence change.
If you hit a specific issue with USB, please file a new bug. Likely the root
cause is different.

I'll close this bug now to avoid confusion.

Note You need to log in before you can comment on or make changes to this bug.