Bug 248558 - upgrade does not recognize swap partition
upgrade does not recognize swap partition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 249487 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-17 10:15 EDT by Steven Legowik
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 16:25:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
my fstab file (927 bytes, text/plain)
2007-07-17 10:15 EDT, Steven Legowik
no flags Details

  None (edit)
Description Steven Legowik 2007-07-17 10:15:54 EDT
I am trying to upgrade my FC6 system to F7.  When I try to upgrade from the F7
install DVD I get the following message (after a complaint about a DOS share
partion and one about fd0):

Error enabling swap device hdb3: No such file or directory
The /etc/fstab on your upgrade partition does not reference a valid swap partition.
Press OK to reboot your system.

I don't know what version of anaconda is running on the F7 install DVD.

Steps to Reproduce:
1. Reboot with F7 install disk
2. Select graphic install/upgrade option on startup screen
3. Select language options (English)
4. Click continue on two dialogs, one complaining about /winshare DOS partition
on hdb2, and one complaining about a mount error for fd0.
5. Get error message above, click OK and we are back to the start.
  
As far as I know there is nothing wrong with the swap partition.  FC6 runs fine.
 I ran mkswap on the partition just to be sure it was good, but it had no effect
on the upgrade.
Comment 1 Steven Legowik 2007-07-17 10:15:55 EDT
Created attachment 159436 [details]
my fstab file
Comment 2 Chris Lumens 2007-07-17 13:46:52 EDT
When you get this error message, can you flip over to tty3 and tty4 and see if
there are any obvious error message?  Your fstab does look okay to me, and I
find it odd that you get error messages about the two partitions in hdb.
Comment 3 J.Jansen 2007-07-18 07:54:44 EDT
Hi

I got the same (except for "step 4") on one of my machines.

Did not try (yet) to flip to tty3 and tty4 (how do you do that?)

                    Jouk
Comment 4 Steven Legowik 2007-07-18 09:56:10 EDT
You flip to the various 'virtual' terminals by using the key combo 
ctrl-alt-Fn, where 'n' is the number of the tty you are switching to.  
ctrl-alt-F6 generally takes you back to the X windows terminal.

To answer the earlier question: No I didn't see any obvious error messages on 
tty3 or tty4.

I did go to the shell on tty2 and did a df.  One odd thing I noticed was that 
the installer had mounted the / and /boot partitions using the /dev/sdc5 
and /dev/sdc1 devices.  Whereas the error message for the /winshare partition, 
and the swap partition indicated that it was trying to use the /dev/hdb2 
and /dev/hdb3 devices.  Is there some reason it is using the SCSI emulation 
for some of the mounts, and the ATA driver for the others (the ones that 
didn't want to mount)?

Is there significance to the fact that / and /boot are specified by label 
in /etc/fstab, and work.  Whereas /winshare and swap are specified as explicit 
devices in /etc/fstab, and do not work?
Comment 5 J.Jansen 2007-07-18 10:52:58 EDT
No obvious error messages in ttyx on my machine either.

Also my swap is specified as explicit device while on all my succesfull upgraded
FC6->F7 machines all have swap specified by label.

Comment 6 Chris Lumens 2007-07-18 16:25:09 EDT
Yes, the problem here is that it's specified by device name instead of label. 
Unfortunately between FC6 and F7, all the device names changed from hdX to sdX
because of underlying kernel changes.  I've improved the error handling here to
tell you what the actual problem is, just like we already had for non-swap
partitions.
Comment 7 J.Jansen 2007-07-19 02:23:29 EDT
Should anaconda not be trying to correct the problem?

Maybe we need for the moment a recipe how to overcome the problem when upgrading
to F7.
Comment 8 Chris Lumens 2007-07-19 09:46:59 EDT
The correct fix for you is to label your devices and then refer to them by label
in your /etc/fstab.  That's what the error message tells you to do.  anaconda
can't correct the problem by simply replacing hdX by sdX, because this is not
guaranteed to work in all cases.
Comment 9 Chris Lumens 2007-07-25 09:47:16 EDT
*** Bug 249487 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.