Bug 249487 - Swap device naming change aborts upgrade
Swap device naming change aborts upgrade
Status: CLOSED DUPLICATE of bug 248558
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 19:44 EDT by Jeremy Rode
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 09:47:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Rode 2007-07-24 19:44:13 EDT
Description of problem:

When upgrading a FC6 box to FC7 with the DVD, choosing "Upgrade existing
installation" (which is correctly found with root
file system on /dev/sda3, the following error message is displayed:

Error enabling swap device hda2: No such file or directory
The /etc/fstab on your upgrade partition does not reference a valid swap partition.
Press OK to reboot your system.

My swap is not mounted using a label, ie:

/dev/hda2    swap    swap    defaults   0 0

The quick fix was to boot back into the FC6 system, and change the above entry to:

/dev/sda2    swap    swap    defaults   0 0

Then immediately boot to the DVD, and the install worked.  Seems like a beginner
user might have a tough time figuring this out.

This is similar to a bug report (Closed):
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249392

Unlike above, this bug seems to be real, as I only have one choice for
upgrading: /dev/sda3.  Also no RAID is on this system.

Seems like an issue with the change to libata device naming.

How reproducible:
Always.

Steps to Reproduce:
1. Boot from installation DVD
2. Choose upgrade
  
Actual results:
Doesn't install.
Comment 1 Chris Lumens 2007-07-25 09:47:14 EDT

*** This bug has been marked as a duplicate of 248558 ***

Note You need to log in before you can comment on or make changes to this bug.